diff mbox series

[bug#51314,25/29] gnu: python-wrapt: Enable tests.

Message ID 20211021040200.241873-21-monego@posteo.net
State New
Headers show
Series Add Octoprint (web UI for 3d printers). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Oct. 21, 2021, 4:01 a.m. UTC
* gnu/packages/python-xyz.scm (python-wrapt)[source]: Fetch from GitHub.
[arguments]: Remove #:tests?. Override 'check phase.
---
 gnu/packages/python-xyz.scm | 21 ++++++++++++++-------
 1 file changed, 14 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5476e3913a..eef7ef5add 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10812,16 +10812,23 @@  Supported netlink families and protocols include:
     (version "1.12.1")
     (source
      (origin
-       (method url-fetch)
-       (uri (pypi-uri "wrapt" version))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/GrahamDumpleton/wrapt")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "1mwpkdnqxf0yxj1a0hsnl06lf287qi5ap7309wm37x45zf0zlbxn"))))
+        (base32 "0943ixbiwixl5ch60vx7i2nia16534zgq2571ldzq1iimq3cz5vj"))))
     (build-system python-build-system)
     (arguments
-     ;; Tests are not included in the tarball, they are only available in the
-     ;; git repository.
-     `(#:tests? #f))
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" "-m" "unittest" "discover"
+                       "-s" "tests")))))))
     (home-page "https://github.com/GrahamDumpleton/wrapt")
     (synopsis "Module for decorators, wrappers and monkey patching")
     (description