diff mbox series

[bug#51314,05/29] gnu: Add python-sarge.

Message ID 20211021040200.241873-1-monego@posteo.net
State New
Headers show
Series Add Octoprint (web UI for 3d printers). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Oct. 21, 2021, 4:01 a.m. UTC
* gnu/packages/python-xyz.scm (python-sarge): New variable.
---
 gnu/packages/python-xyz.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 07d2a9da41..4230f141bb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9743,6 +9743,23 @@  entire set of Emoji codes as defined by the unicode consortium is supported in
 addition to a bunch of aliases.")
     (license license:bsd-3)))
 
+(define-public python-sarge
+  (package
+    (name "python-sarge")
+    (version "0.1.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "sarge" version))
+       (sha256
+        (base32 "0r9jnpdsjdr6h92blr5b2fdzvb1n8ypjwhk2xxmss42gwq2bk3zl"))))
+    (build-system python-build-system)
+    (home-page "https://sarge.readthedocs.io/")
+    (synopsis "Command pipeline functionality")
+    (description "@code{sarge} is a wrapper for subprocess which provides
+command pipeline functionality.")
+    (license license:bsd-3)))
+
 (define-public python-pep8
   ;; This package has been renamed to ‘pycodestyle’ and is no longer updated.
   ;; Its last release (1.7.1) adds only a scary warning to this effect, breaking