diff mbox series

[bug#50835,8/8] gnu: Add ghc-network-protocol-xmpp.

Message ID 20210927021033.17700-8-singpolyma@singpolyma.net
State New
Headers show
Series New Haskell packages: cache, redis client, xmpp | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Stephen Paul Weber Sept. 27, 2021, 2:10 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-network-protocol-xmpp): New variable.
---
 gnu/packages/haskell-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 44ab7072c9..433f444a74 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -15941,3 +15941,32 @@  than the standard TCP connection.")
     (synopsis "Bindings for GNU IDN")
     (description "Low-level bindings for using libidn in Haskell.")
     (license license:gpl3)))
+
+(define-public ghc-network-protocol-xmpp
+  (package
+    (name "ghc-network-protocol-xmpp")
+    (version "0.4.9")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://hackage.haskell.org/package/"
+               "network-protocol-xmpp/network-protocol-xmpp-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32 "1qjm22qvsmfsf9kmg0ha117yidys0yp80mawvnzs8ym5a6j80x42"))))
+    (build-system haskell-build-system)
+    (inputs
+      `(("ghc-gnuidn" ,ghc-gnuidn)
+        ("ghc-gnutls" ,ghc-gnutls)
+        ("ghc-gsasl" ,ghc-gsasl)
+        ("ghc-libxml-sax" ,ghc-libxml-sax)
+        ("ghc-monads-tf" ,ghc-monads-tf)
+        ("ghc-network" ,ghc-network)
+        ("ghc-xml-types" ,ghc-xml-types)))
+    (home-page "https://git.singpolyma.net/network-protocol-xmpp")
+    (synopsis "Client library for the XMPP protocol")
+    (description "Client or component library for XMPP in Haskell.
+Does only what it needs to and nothing more, no XEP wrappers, etc.")
+    (license license:gpl3)))