diff mbox series

[bug#50835,4/8] gnu: Add ghc-libxml-sax.

Message ID 20210927021033.17700-4-singpolyma@singpolyma.net
State New
Headers show
Series New Haskell packages: cache, redis client, xmpp | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Stephen Paul Weber Sept. 27, 2021, 2:10 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-libxml-sax): New variable.
---
 gnu/packages/haskell-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 55efd9da2b..0e00bc0605 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -15831,3 +15831,26 @@  TCP sockets are the default way to connect to a Redis server.  For connections
 to a server on the same machine, Unix domain sockets offer higher performance
 than the standard TCP connection.")
     (license license:bsd-3)))
+
+(define-public ghc-libxml-sax
+  (package
+    (name "ghc-libxml-sax")
+    (version "0.7.5")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://hackage.haskell.org/package/libxml-sax/libxml-sax-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32 "0lbdq6lmiyrnzk6gkx09vvp928wj8qnqnqfzy14mfv0drj21f54r"))))
+    (build-system haskell-build-system)
+    (inputs
+      `(("ghc-xml-types" ,ghc-xml-types)
+        ("libxml2" ,libxml2)))
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (home-page "https://hackage.haskell.org/package/libxml-sax")
+    (synopsis "Bindings for the libXML2 SAX interface")
+    (description "A very simple and direct binding to libXML2's SAX parser.")
+    (license license:expat)))