diff mbox series

[bug#50835,1/8] gnu: Add ghc-cache.

Message ID 20210927021033.17700-1-singpolyma@singpolyma.net
State New
Headers show
Series New Haskell packages: cache, redis client, xmpp | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Stephen Paul Weber Sept. 27, 2021, 2:10 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-cache): New variable.
---
 gnu/packages/haskell-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index f421458e15..f5ae156d35 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -15712,3 +15712,32 @@  Zstandard compression algorithm, a fast lossless compression algorithm
 targeting real-time compression scenarios at zlib-level and better
 compression ratios.")
     (license license:bsd-3)))
+
+(define-public ghc-cache
+  (package
+    (name "ghc-cache")
+    (version "0.1.3.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://hackage.haskell.org/package/cache/cache-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32 "0d75257kvjpnv95ja50x5cs77pj8ccfr0nh9q5gzvcps83qdksa2"))))
+    (build-system haskell-build-system)
+    (inputs
+      `(("ghc-clock" ,ghc-clock)
+        ("ghc-hashable" ,ghc-hashable)
+        ("ghc-unordered-containers" ,ghc-unordered-containers)))
+    (native-inputs
+      `(("ghc-hspec" ,ghc-hspec)
+        ("hspec-discover" ,hspec-discover)))
+    (home-page "https://github.com/hverr/haskell-cache#readme")
+    (synopsis "In-memory key/value store with expiration support")
+    (description
+      "An in-memory key/value store with expiration support, similar to
+patrickmn/go-cache for Go.  The cache is a shared mutable HashMap implemented
+using STM and with support for expiration times.")
+    (license license:bsd-3)))