diff mbox series

[bug#49867,v2,31/31] gnu: Add ocaml-cohttp-lwt-unix

Message ID 20210809070124.25641-31-pukkamustard@posteo.net
State Accepted
Headers show
Series [bug#49867,v2,01/31] gnu: Add ocaml-cohttp-lwt. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

pukkamustard Aug. 9, 2021, 7:01 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-cohttp-lwt-unix): New variable.
---
 gnu/packages/ocaml.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 42e6fd2e94..8965f5920d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7424,6 +7424,29 @@  JavaScript backend, or @code{ocaml-cohttp-mirage} for the MirageOS unikernel
 version of the library.  All of these implementations share the same IO logic
 from this module.")))
 
+(define-public ocaml-cohttp-lwt-unix
+  (package
+    (inherit ocaml-cohttp)
+    (name "ocaml-cohttp-lwt-unix")
+    (arguments `(#:package "cohttp-lwt-unix"
+                 ;; tests require network
+                 #:tests? #f))
+    (propagated-inputs
+     `(("ocaml-conduit-lwt" ,ocaml-conduit-lwt)
+       ("ocaml-conduit-lwt-unix" ,ocaml-conduit-lwt-unix)
+       ("ocaml-cmdliner" ,ocaml-cmdliner)
+       ("ocaml-magic-mime" ,ocaml-magic-mime)
+       ("ocaml-logs" ,ocaml-logs)
+       ("ocaml-fmt" ,ocaml-fmt)
+       ("ocaml-cohttp-lwt" ,ocaml-cohttp-lwt)
+       ("ocaml-ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
+       ("ocaml-lwt" ,ocaml-lwt)
+       ("ocaml-lwt-ssl" ,ocaml-lwt-ssl)))
+    (native-inputs `(("ocaml-ounit" ,ocaml-ounit)))
+    (synopsis "OCaml HTTP implementation for Unix using Lwt")
+    (description "This Ocaml package provides an implementation of an HTTP
+client and server for Unix using the Lwt concurrency library.")))
+
 (define-public ocaml-magic-mime
   (package
     (name "ocaml-magic-mime")