diff mbox series

[bug#49867,v2,11/31] gnu: Add ocaml-crowbar.

Message ID 20210809070124.25641-11-pukkamustard@posteo.net
State Accepted
Headers show
Series [bug#49867,v2,01/31] gnu: Add ocaml-cohttp-lwt. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

pukkamustard Aug. 9, 2021, 7:01 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-crowbar): New variable.
---
 gnu/packages/ocaml.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comments

Xinglu Chen Aug. 9, 2021, 9:51 a.m. UTC | #1
On Mon, Aug 09 2021, pukkamustard wrote:

> * gnu/packages/ocaml.scm (ocaml-crowbar): New variable.
> ---
>  gnu/packages/ocaml.scm | 36 ++++++++++++++++++++++++++++++++++++
>  1 file changed, 36 insertions(+)
>
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index 5a7acb4ba8..dba715d2f5 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -7528,6 +7528,42 @@ breaks, while respecting the constraints imposed by the structure of the
>  document and by the text width.")
>      (license license:lgpl2.0)))
>  
> +(define-public ocaml-crowbar
> +  (package
> +    (name "ocaml-crowbar")
> +    (version "0.2")
> +    (home-page "https://github.com/stedolan/crowbar")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url home-page)
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> +         "0wjfc9irvirfkic32ivvj6qb7r838w08b0d3vmngigbjpjyc9b14"))))
> +    (build-system dune-build-system)
> +    (arguments
> +     ;; Tests require ocaml-xmldiff which requires OCaml 4.12.0
> +     `(#:tests? #f))
> +    (propagated-inputs
> +     `(("ocaml-ocplib-endian" ,ocaml-ocplib-endian)
> +       ("ocaml-cmdliner" ,ocaml-cmdliner)
> +       ("ocaml-afl-persistent" ,ocaml-afl-persistent)))
> +    (native-inputs
> +     `(("ocaml-calendar" ,ocaml-calendar)
> +       ("ocaml-fpath" ,ocaml-fpath)
> +       ("ocaml-uucp" ,ocaml-uucp)

The ‘ocaml-uucp’ package hasn’t been packaged yet.

> +       ("ocaml-uunf" ,ocaml-uunf)
> +       ("ocaml-uutf" ,ocaml-uutf)
> +       ("ocaml-pprint" ,ocaml-pprint)))
> +    (synopsis "Ocaml library for tests, let a fuzzer find failing cases")
> +    (description "Crowbar is a library for testing code, combining QuickCheck-style
> +property-based testing and the magical bug-finding powers of
> +[afl-fuzz](http://lcamtuf.coredump.cx/afl/).")

Texinfo formatting:

  @uref{http://lcamtuf.coredump.cx/afl/, afl-fuzz}

The rest of v2 looks good.  :-)
Julien Lepiller Aug. 9, 2021, 11:13 a.m. UTC | #2
Le 9 août 2021 05:51:58 GMT-04:00, Xinglu Chen <public@yoctocell.xyz> a écrit :
>On Mon, Aug 09 2021, pukkamustard wrote:
>
>> * gnu/packages/ocaml.scm (ocaml-crowbar): New variable.
>> ---
>>  gnu/packages/ocaml.scm | 36 ++++++++++++++++++++++++++++++++++++
>>  1 file changed, 36 insertions(+)
>>
>> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
>> index 5a7acb4ba8..dba715d2f5 100644
>> --- a/gnu/packages/ocaml.scm
>> +++ b/gnu/packages/ocaml.scm
>> @@ -7528,6 +7528,42 @@ breaks, while respecting the constraints imposed by the structure of the
>>  document and by the text width.")
>>      (license license:lgpl2.0)))
>>  
>> +(define-public ocaml-crowbar
>> +  (package
>> +    (name "ocaml-crowbar")
>> +    (version "0.2")
>> +    (home-page "https://github.com/stedolan/crowbar")
>> +    (source
>> +     (origin
>> +       (method git-fetch)
>> +       (uri (git-reference
>> +             (url home-page)
>> +             (commit (string-append "v" version))))
>> +       (file-name (git-file-name name version))
>> +       (sha256
>> +        (base32
>> +         "0wjfc9irvirfkic32ivvj6qb7r838w08b0d3vmngigbjpjyc9b14"))))
>> +    (build-system dune-build-system)
>> +    (arguments
>> +     ;; Tests require ocaml-xmldiff which requires OCaml 4.12.0
>> +     `(#:tests? #f))
>> +    (propagated-inputs
>> +     `(("ocaml-ocplib-endian" ,ocaml-ocplib-endian)
>> +       ("ocaml-cmdliner" ,ocaml-cmdliner)
>> +       ("ocaml-afl-persistent" ,ocaml-afl-persistent)))
>> +    (native-inputs
>> +     `(("ocaml-calendar" ,ocaml-calendar)
>> +       ("ocaml-fpath" ,ocaml-fpath)
>> +       ("ocaml-uucp" ,ocaml-uucp)
>
>The ‘ocaml-uucp’ package hasn’t been packaged yet.

It has, I just pushed it yesterday :)

>
>> +       ("ocaml-uunf" ,ocaml-uunf)
>> +       ("ocaml-uutf" ,ocaml-uutf)
>> +       ("ocaml-pprint" ,ocaml-pprint)))
>> +    (synopsis "Ocaml library for tests, let a fuzzer find failing cases")
>> +    (description "Crowbar is a library for testing code, combining QuickCheck-style
>> +property-based testing and the magical bug-finding powers of
>> +[afl-fuzz](http://lcamtuf.coredump.cx/afl/).")
>
>Texinfo formatting:
>
>  @uref{http://lcamtuf.coredump.cx/afl/, afl-fuzz}
>
>The rest of v2 looks good.  :-)
>
Xinglu Chen Aug. 9, 2021, 12:39 p.m. UTC | #3
On Mon, Aug 09 2021, Julien Lepiller wrote:

> Le 9 août 2021 05:51:58 GMT-04:00, Xinglu Chen <public@yoctocell.xyz> a écrit :
>>On Mon, Aug 09 2021, pukkamustard wrote:
>>
>>> * gnu/packages/ocaml.scm (ocaml-crowbar): New variable.
>>> ---
>>>  gnu/packages/ocaml.scm | 36 ++++++++++++++++++++++++++++++++++++
>>>  1 file changed, 36 insertions(+)
>>>
>>> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
>>> index 5a7acb4ba8..dba715d2f5 100644
>>> --- a/gnu/packages/ocaml.scm
>>> +++ b/gnu/packages/ocaml.scm
>>> @@ -7528,6 +7528,42 @@ breaks, while respecting the constraints imposed by the structure of the
>>>  document and by the text width.")
>>>      (license license:lgpl2.0)))
>>>  
>>> +(define-public ocaml-crowbar
>>> +  (package
>>> +    (name "ocaml-crowbar")
>>> +    (version "0.2")
>>> +    (home-page "https://github.com/stedolan/crowbar")
>>> +    (source
>>> +     (origin
>>> +       (method git-fetch)
>>> +       (uri (git-reference
>>> +             (url home-page)
>>> +             (commit (string-append "v" version))))
>>> +       (file-name (git-file-name name version))
>>> +       (sha256
>>> +        (base32
>>> +         "0wjfc9irvirfkic32ivvj6qb7r838w08b0d3vmngigbjpjyc9b14"))))
>>> +    (build-system dune-build-system)
>>> +    (arguments
>>> +     ;; Tests require ocaml-xmldiff which requires OCaml 4.12.0
>>> +     `(#:tests? #f))
>>> +    (propagated-inputs
>>> +     `(("ocaml-ocplib-endian" ,ocaml-ocplib-endian)
>>> +       ("ocaml-cmdliner" ,ocaml-cmdliner)
>>> +       ("ocaml-afl-persistent" ,ocaml-afl-persistent)))
>>> +    (native-inputs
>>> +     `(("ocaml-calendar" ,ocaml-calendar)
>>> +       ("ocaml-fpath" ,ocaml-fpath)
>>> +       ("ocaml-uucp" ,ocaml-uucp)
>>
>>The ‘ocaml-uucp’ package hasn’t been packaged yet.
>
> It has, I just pushed it yesterday :)

Ah, forgot to pull :-)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 5a7acb4ba8..dba715d2f5 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7528,6 +7528,42 @@  breaks, while respecting the constraints imposed by the structure of the
 document and by the text width.")
     (license license:lgpl2.0)))
 
+(define-public ocaml-crowbar
+  (package
+    (name "ocaml-crowbar")
+    (version "0.2")
+    (home-page "https://github.com/stedolan/crowbar")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0wjfc9irvirfkic32ivvj6qb7r838w08b0d3vmngigbjpjyc9b14"))))
+    (build-system dune-build-system)
+    (arguments
+     ;; Tests require ocaml-xmldiff which requires OCaml 4.12.0
+     `(#:tests? #f))
+    (propagated-inputs
+     `(("ocaml-ocplib-endian" ,ocaml-ocplib-endian)
+       ("ocaml-cmdliner" ,ocaml-cmdliner)
+       ("ocaml-afl-persistent" ,ocaml-afl-persistent)))
+    (native-inputs
+     `(("ocaml-calendar" ,ocaml-calendar)
+       ("ocaml-fpath" ,ocaml-fpath)
+       ("ocaml-uucp" ,ocaml-uucp)
+       ("ocaml-uunf" ,ocaml-uunf)
+       ("ocaml-uutf" ,ocaml-uutf)
+       ("ocaml-pprint" ,ocaml-pprint)))
+    (synopsis "Ocaml library for tests, let a fuzzer find failing cases")
+    (description "Crowbar is a library for testing code, combining QuickCheck-style
+property-based testing and the magical bug-finding powers of
+[afl-fuzz](http://lcamtuf.coredump.cx/afl/).")
+    (license license:expat)))
+
 (define-public js-of-ocaml
   (package
     (name "js-of-ocaml")