diff mbox series

[bug#49867,v2,25/31] gnu: Add ocaml-cstruct-unix.

Message ID 20210809070124.25641-25-pukkamustard@posteo.net
State Accepted
Headers show
Series [bug#49867,v2,01/31] gnu: Add ocaml-cohttp-lwt. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

pukkamustard Aug. 9, 2021, 7:01 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-cstruct-unix): New variable.
---
 gnu/packages/ocaml.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index df825d1ec3..e358042e41 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3412,6 +3412,23 @@  to access C-like structures directly from OCaml.  It supports both reading and
 writing to these structures, and they are accessed via the Bigarray module.")
     (license license:isc)))
 
+(define-public ocaml-cstruct-unix
+  (package
+    (inherit ocaml-cstruct)
+    (name "ocaml-cstruct-unix")
+    (build-system dune-build-system)
+    (arguments
+     `(#:package "cstruct-unix"
+       #:test-target "."))
+    (propagated-inputs
+     `(("ocaml-cstruct" ,ocaml-cstruct)))
+    (synopsis "Unix variation of the @code{ocaml-cstruct} library")
+    (description "Cstruct is a library and syntax extension to make it easier
+to access C-like structures directly from OCaml.  It supports both reading and
+writing to these structures, and they are accessed via the `Bigarray`
+module.")
+    (license license:isc)))
+
 (define-public ocaml-hex
   (package
     (name "ocaml-hex")