diff mbox series

[bug#49386,05/21] gnu: Add rust-postgres-0.19

Message ID 20210704163203.31351-6-ds815@gmx.com
State Accepted
Headers show
Series Add hyperfine | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Domagoj Stolfa July 4, 2021, 4:31 p.m. UTC
* gnu/packages/crates-io.scm (rust-postgres-0.19): New public variable.
---
 gnu/packages/crates-io.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Xinglu Chen July 11, 2021, 8:53 a.m. UTC | #1
On Sun, Jul 04 2021, Domagoj Stolfa wrote:

> * gnu/packages/crates-io.scm (rust-postgres-0.19): New public variable.
> ---
>  gnu/packages/crates-io.scm | 33 +++++++++++++++++++++++++++++++++
>  1 file changed, 33 insertions(+)
>
> diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> index 61641c9a05..b77c044dbf 100644
> --- a/gnu/packages/crates-io.scm
> +++ b/gnu/packages/crates-io.scm
> @@ -32516,6 +32516,39 @@ UDP.")
>       "This package provides a native, synchronous PostgreSQL client.")
>      (license license:expat)))
>  
> +(define-public rust-postgres-0.19
> +  (package
> +    (name "rust-postgres")
> +    (version "0.19.1")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (crate-uri "postgres" version))
> +        (file-name
> +          (string-append name "-" version ".tar.gz"))
> +        (sha256
> +          (base32
> +            "1hnid1d78zrr8ph12lpvp5b2cpx2fsqqgqs2yn1q23c6g7jix1y7"))))
> +    (build-system cargo-build-system)
> +    (arguments
> +      `(#:cargo-inputs
> +        (("rust-bytes" ,rust-bytes-1)
> +         ("rust-fallible-iterator"
> +          ,rust-fallible-iterator-0.2)
> +         ("rust-futures" ,rust-futures-0.3)
> +         ("rust-log" ,rust-log-0.4)
> +         ("rust-tokio" ,rust-tokio-1)
> +         ("rust-tokio-postgres" ,rust-tokio-postgres-0.7))
> +        #:cargo-development-inputs
> +        (("rust-criterion" ,rust-criterion-0.3))))
> +    (home-page
> +      "https://github.com/sfackler/rust-postgres")
> +    (synopsis
> +      "A native, synchronous PostgreSQL client")

Avoid words like “a” and “the” in the synopsis, see “16.4.4 Synopses and
Descriptions” in the manual.

> +    (description
> +      "This package provides a native, synchronous PostgreSQL client")

Missing period.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 61641c9a05..b77c044dbf 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -32516,6 +32516,39 @@  UDP.")
      "This package provides a native, synchronous PostgreSQL client.")
     (license license:expat)))
 
+(define-public rust-postgres-0.19
+  (package
+    (name "rust-postgres")
+    (version "0.19.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "postgres" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "1hnid1d78zrr8ph12lpvp5b2cpx2fsqqgqs2yn1q23c6g7jix1y7"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:cargo-inputs
+        (("rust-bytes" ,rust-bytes-1)
+         ("rust-fallible-iterator"
+          ,rust-fallible-iterator-0.2)
+         ("rust-futures" ,rust-futures-0.3)
+         ("rust-log" ,rust-log-0.4)
+         ("rust-tokio" ,rust-tokio-1)
+         ("rust-tokio-postgres" ,rust-tokio-postgres-0.7))
+        #:cargo-development-inputs
+        (("rust-criterion" ,rust-criterion-0.3))))
+    (home-page
+      "https://github.com/sfackler/rust-postgres")
+    (synopsis
+      "A native, synchronous PostgreSQL client")
+    (description
+      "This package provides a native, synchronous PostgreSQL client")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-postgres-protocol-0.3
   (package
     (name "rust-postgres-protocol")