diff mbox series

[bug#49403,20/21] gnu: Add rust-postgres-derive-0.4

Message ID 20210704163203.31351-21-ds815@gmx.com
State Accepted
Headers show
Series Add hyperfine | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Domagoj Stolfa July 4, 2021, 4:32 p.m. UTC
* gnu/packages/crates-io.scm (rust-postgres-derive-0.4): New public variable.
---
 gnu/packages/crates-io.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Xinglu Chen July 11, 2021, 9:19 a.m. UTC | #1
On Sun, Jul 04 2021, Domagoj Stolfa wrote:

> * gnu/packages/crates-io.scm (rust-postgres-derive-0.4): New public variable.
> ---
>  gnu/packages/crates-io.scm | 27 +++++++++++++++++++++++++++
>  1 file changed, 27 insertions(+)
>
> diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> index 8ec8506c94..ab2e6dbb01 100644
> --- a/gnu/packages/crates-io.scm
> +++ b/gnu/packages/crates-io.scm
> @@ -32778,6 +32778,33 @@ UDP.")
>        "This package provides a native, synchronous PostgreSQL client")
>      (license (list license:expat license:asl2.0))))
>  
> +(define-public rust-postgres-derive-0.4
> +  (package
> +    (name "rust-postgres-derive")
> +    (version "0.4.0")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (crate-uri "postgres-derive" version))
> +        (file-name
> +          (string-append name "-" version ".tar.gz"))
> +        (sha256
> +          (base32
> +            "0xqlf1gffy3q8hra3fm0vm9x8i5fkvi0qjl99d0xirxh3hidsmy8"))))
> +    (build-system cargo-build-system)
> +    (arguments
> +      `(#:cargo-inputs
> +        (("rust-proc-macro2" ,rust-proc-macro2-1)
> +         ("rust-quote" ,rust-quote-1)
> +         ("rust-syn" ,rust-syn-1))))
> +    (home-page
> +      "https://github.com/sfackler/rust-postgres")
> +    (synopsis
> +      "An internal crate used by postgres-types")

Avoid using words like “an” and “the” in the synopsis.

> +    (description
> +      "An internal crate used by postgres-types")

Full sentence.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8ec8506c94..ab2e6dbb01 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -32778,6 +32778,33 @@  UDP.")
       "This package provides a native, synchronous PostgreSQL client")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-postgres-derive-0.4
+  (package
+    (name "rust-postgres-derive")
+    (version "0.4.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "postgres-derive" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "0xqlf1gffy3q8hra3fm0vm9x8i5fkvi0qjl99d0xirxh3hidsmy8"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:cargo-inputs
+        (("rust-proc-macro2" ,rust-proc-macro2-1)
+         ("rust-quote" ,rust-quote-1)
+         ("rust-syn" ,rust-syn-1))))
+    (home-page
+      "https://github.com/sfackler/rust-postgres")
+    (synopsis
+      "An internal crate used by postgres-types")
+    (description
+      "An internal crate used by postgres-types")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-postgres-protocol-0.3
   (package
     (name "rust-postgres-protocol")