diff mbox series

[bug#49390,09/21] gnu: Add rust-socket2-0.4

Message ID 20210704163203.31351-10-ds815@gmx.com
State Accepted
Headers show
Series Add hyperfine | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Domagoj Stolfa July 4, 2021, 4:31 p.m. UTC
* gnu/packages/crates-io.scm (rust-socket2-0.4): New public variable.
---
 gnu/packages/crates-io.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Xinglu Chen July 11, 2021, 8:59 a.m. UTC | #1
On Sun, Jul 04 2021, Domagoj Stolfa wrote:

> * gnu/packages/crates-io.scm (rust-socket2-0.4): New public variable.
> ---
>  gnu/packages/crates-io.scm | 30 ++++++++++++++++++++++++++++++
>  1 file changed, 30 insertions(+)
>
> diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> index 79937fb40a..055730505b 100644
> --- a/gnu/packages/crates-io.scm
> +++ b/gnu/packages/crates-io.scm
> @@ -43154,6 +43154,36 @@ maximal amount of configuration possible intended.")
>      (license (list license:asl2.0
>                     license:expat))))
>  
> +(define-public rust-socket2-0.4
> +  (package
> +    (name "rust-socket2")
> +    (version "0.4.0")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (crate-uri "socket2" version))
> +        (file-name
> +          (string-append name "-" version ".tar.gz"))
> +        (sha256
> +          (base32
> +            "18ny6m1gnf6cwp5ax0b5hr36w6yg16z7faj76b31aq2jghhgqgcy"))))
> +    (build-system cargo-build-system)
> +    (arguments
> +      `(#:cargo-inputs
> +        (("rust-libc" ,rust-libc-0.2)
> +         ("rust-winapi" ,rust-winapi-0.3))))
> +    (home-page
> +      "https://github.com/rust-lang/socket2")
> +    (synopsis
> +      "Utilities for handling networking sockets with a maximal amount of configuration
> +possible intended.

The synopsis is a bit long, the GitHub repo says

  Advanced configuration options for sockets

maybe we can use that instead?

> +    (description
> +      "Utilities for handling networking sockets with a maximal amount of configuration
> +possible intended.
> +")

Full sentence, and don’t forget line break.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 79937fb40a..055730505b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -43154,6 +43154,36 @@  maximal amount of configuration possible intended.")
     (license (list license:asl2.0
                    license:expat))))
 
+(define-public rust-socket2-0.4
+  (package
+    (name "rust-socket2")
+    (version "0.4.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "socket2" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "18ny6m1gnf6cwp5ax0b5hr36w6yg16z7faj76b31aq2jghhgqgcy"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:cargo-inputs
+        (("rust-libc" ,rust-libc-0.2)
+         ("rust-winapi" ,rust-winapi-0.3))))
+    (home-page
+      "https://github.com/rust-lang/socket2")
+    (synopsis
+      "Utilities for handling networking sockets with a maximal amount of configuration
+possible intended.
+")
+    (description
+      "Utilities for handling networking sockets with a maximal amount of configuration
+possible intended.
+")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-socks-0.3
   (package
     (name "rust-socks")