diff mbox series

[bug#48729,v2,28/47] gnu: Add go-github-com-getlantern-hex.

Message ID 20210603104507.22412-28-rg@raghavgururajan.name
State Accepted
Headers show
Series None | expand

Commit Message

Raghav Gururajan June 3, 2021, 10:44 a.m. UTC
* gnu/packages/golang.scm (go-github-com-getlantern-hex): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9e94c8e43d..376cce1fc9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -69,6 +69,30 @@ 
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1))
 
+(define-public go-github-com-getlantern-hex
+  (let ((commit "c6586a6fe0b7c95eef767657ab1031cbcfc7af66")
+        (revision "4"))
+    (package
+      (name "go-github-com-getlantern-hex")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/getlantern/hex")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "09vbm93y88b8hwv15rqkzrmrjqzl5zj8bijllzh8npibqhh84qsq"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/getlantern/hex"))
+      (synopsis "Configurable hex encoding")
+      (description "Configurable hex encoding.")
+      (home-page "https://github.com/getlantern/hex")
+      (license license:bsd-3))))
+
 (define-public go-github-com-getlantern-ops
   (let ((commit "8476b16edcd6719b2399ae70bca5cff3a1547a44")
         (revision "21"))