diff mbox series

[bug#48729,v2,27/47] gnu: Add go-github-com-getlantern-ops.

Message ID 20210603104507.22412-27-rg@raghavgururajan.name
State Accepted
Headers show
Series None | expand

Commit Message

Raghav Gururajan June 3, 2021, 10:44 a.m. UTC
* gnu/packages/golang.scm (go-github-com-getlantern-ops): New variable.
---
 gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7ccb085587..9e94c8e43d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -69,6 +69,34 @@ 
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1))
 
+(define-public go-github-com-getlantern-ops
+  (let ((commit "8476b16edcd6719b2399ae70bca5cff3a1547a44")
+        (revision "21"))
+    (package
+      (name "go-github-com-getlantern-ops")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/getlantern/ops")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1mh2xp48x9im4l736l5zxz38kghxa5624nlyfaxmj18xn0jxr8nn"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:tests? #f    ; circular-dependency with 'getlantern/errors'
+         #:import-path "github.com/getlantern/ops"))
+      (propagated-inputs
+       `(("go-github-com-getlantern-context"
+          ,go-github-com-getlantern-context)))
+      (synopsis "Track success or failure of operations in code")
+      (description "Track success or failure of operations in code.")
+      (home-page "https://github.com/getlantern/ops")
+      (license license:asl2.0))))
+
 (define-public go-github-com-getlantern-context
   (let ((commit "c447772a6520c1a3ae6294a7df725ee08230f14e")
         (revision "30"))