diff mbox series

[bug#48729,v2,36/47] gnu: Add go-github-com-jmshal-go-locale.

Message ID 20210603104507.22412-36-rg@raghavgururajan.name
State Accepted
Headers show
Series None | expand

Commit Message

Raghav Gururajan June 3, 2021, 10:44 a.m. UTC
* gnu/packages/golang.scm (go-github-com-jmshal-go-locale): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ad0ba57b78..d9a2f40285 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -72,6 +72,30 @@ 
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1))
 
+(define-public go-github-com-jmshal-go-locale
+  (let ((commit "eb00fb25cc61bca7a5331ae576ae4a3d5572a1e4")
+        (revision "8"))
+    (package
+      (name "go-github-com-jmshal-go-locale")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/jmshal/go-locale")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "05lyrcsrj0vzk30laa9zyy574ijh6f0ybzdv65w4l6n5yibjgnwa"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/jmshal/go-locale"))
+      (synopsis "User locale detection for Go")
+      (description "User locale detection for Go.")
+      (home-page "https://github.com/jmshal/go-locale")
+      (license license:expat))))
+
 (define-public go-github-com-gotk3-gotk3
   (package
     (name "go-github-com-gotk3-gotk3")