diff mbox series

[bug#48622,core-updates,02/29] gnu: Add texlive-latex-refcount.

Message ID 20210524144333.15566-2-marius@gnu.org
State Accepted
Headers show
Series [bug#48622,core-updates,01/29] gnu: TeX Live: Update to 2020.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Marius Bakke May 24, 2021, 2:43 p.m. UTC
* gnu/packages/tex.scm (texlive-latex-refcount): New public variable.
---
 gnu/packages/tex.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1cf288ee2f..8a3f8cb9ba 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4244,6 +4244,25 @@  re-processing.")
 (define-public texlive-latex-pstool
   (deprecated-package "texlive-latex-pstool" texlive-pstool))
 
+(define-public texlive-latex-refcount
+  (package
+    (inherit (simple-texlive-package
+              "texlive-latex-refcount"
+              (list "/doc/latex/refcount/"
+                    "/tex/latex/refcount/")
+              (base32
+               "0pkmqj2qihndlv3ks33xzqw91q46jx79r3aygj68d8dflyddi583")
+              #:trivial? #t))
+    (home-page "https://www.ctan.org/pkg/refcount")
+    (synopsis "Counter operations with label references")
+    (description
+     "This package provides the @code{\\setcounterref} and
+@code{\\addtocounterref} commands which use the section (or other) number
+from the reference as the value to put into the counter.  It also provides
+@code{\\setcounterpageref} and @code{\\addtocounterpageref} that do the
+corresponding thing with the page reference of the label.")
+    (license license:lppl1.3c+)))
+
 (define-public texlive-seminar
   (package
     (inherit (simple-texlive-package