diff mbox series

[bug#48622,core-updates,11/29] gnu: Add texlive-generic-ltxcmds.

Message ID 20210524144333.15566-11-marius@gnu.org
State Accepted
Headers show
Series [bug#48622,core-updates,01/29] gnu: TeX Live: Update to 2020.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Marius Bakke May 24, 2021, 2:43 p.m. UTC
* gnu/packages/tex.scm (texlive-generic-ltxcmds): New public variable.
---
 gnu/packages/tex.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0f4527bcc2..a6a0369111 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7295,6 +7295,22 @@  the parsing character has been selected by the user, and to access any of
 these items with a simple syntax.")
     (license license:lppl1.3c+)))
 
+(define-public texlive-generic-ltxcmds
+  (package
+    (inherit (simple-texlive-package
+              "texlive-generic-ltxcmds"
+              '("/tex/generic/ltxcmds/")
+              (base32
+               "0mdzy76sbc3pmas5zqxn35w9xcg4v7j4p31jcjm9f4hzm27y974a")
+              #:trivial? #t))
+    (home-page "https://www.ctan.org/pkg/ltxcmds")
+    (synopsis "LaTeX kernel commands extracted for general use")
+    (description
+     "This package exports some utility macros from the LaTeX kernel into
+a separate namespace and also makes them available for other formats such
+as plain TeX.")
+    (license license:lppl1.3c+)))
+
 (define-public texlive-latex-readarray
   (package
     (name "texlive-latex-readarray")