diff mbox series

[bug#48430,5/5] gnu: Add python-multiplex.

Message ID 20210514211746.143145-5-stefan@xsteve.at
State New
Headers show
Series [bug#48428,1/5] gnu: python-pyte: Update to 0.8.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stefan Reichör May 14, 2021, 9:17 p.m. UTC
* gnu/packages/python-xyz.scm (python-multiplex): New variable.
---
 gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 431f2aa85d..ff2ce6ad32 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24983,6 +24983,34 @@  applications with variable CPU loads).")
 (define-public python2-parallel
   (package-with-python2 python-parallel))
 
+(define-public python-multiplex
+  (package
+    (name "python-multiplex")
+    (version "0.5.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "multiplex" version))
+        (sha256
+          (base32
+            "1g01xwx5z0m1dvp5d69ndj8hz80d2z5xzasixa7c0k6ny93f9qhg"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      `(("python-aiofiles" ,python-aiofiles-0.5.0)
+        ("python-aiostream" ,python-aiostream)
+        ("python-click" ,python-click)
+        ("python-easy-ansi" ,python-easy-ansi)
+        ("python-pyte" ,python-pyte)))
+    (home-page
+      "https://github.com/dankilman/multiplex")
+    (synopsis
+      "View output of multiple processes, in parallel, in the console, with an
+interactive TUI")
+    (description
+      "Can be used as cli tool or as python library to view output of parallel
+running processes")
+    (license license:expat)))
+
 (define-public python-djvulibre
   (package
     (name "python-djvulibre")