diff mbox series

[bug#48426,2/5] gnu: Add python-easy-ansi.

Message ID 20210514211746.143145-2-stefan@xsteve.at
State Accepted
Headers show
Series [bug#48428,1/5] gnu: python-pyte: Update to 0.8.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stefan Reichör May 14, 2021, 9:17 p.m. UTC
* gnu/packages/python-xyz.scm (python-easy-ansi): New variable.
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cf0eba3234..98368129ed 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16499,6 +16499,31 @@  converting text with ANSI color codes to HTML or LaTeX.")
 (define-public python2-ansi2html
   (package-with-python2 python-ansi2html))
 
+(define-public python-easy-ansi
+  (package
+    (name "python-easy-ansi")
+    (version "0.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "easy-ansi" version))
+        (sha256
+          (base32
+            "06ind48rb6bc8givysnak60g3rhk0zmch9ar80r00gzc6k6bgqfp"))))
+    (build-system python-build-system)
+    (home-page
+      "https://gitlab.com/joeysbytes/easy-ansi")
+    (synopsis
+      "Terminal framework API to give you an easy way to use colors, cursor
+control movements, and line/box drawing.")
+    (description
+      "Easy ANSI is a terminal framework API to give you an easy way to use
+colors, cursor control movements, and line/box drawing.  It is not meant as a
+replacement to more full-featured frameworks (such as curses or urwid), but as
+a tool to quickly create nice-looking screens in your terminal window.  You
+can even create animations with the cursor controls.")
+    (license license:expat)))
+
 (define-public python-ddt
   (package
     (name "python-ddt")