diff mbox series

[bug#48361,3/5] gnu: Add go-github-com-containerd-console.

Message ID 20210511185554.67355-3-stefan@xsteve.at
State Accepted
Headers show
Series [bug#48362,1/5] gnu: go-github-com-muesli-reflow-wordwrap: Update to 0.2.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stefan Reichör May 11, 2021, 6:55 p.m. UTC
* gnu/packages/golang.scm (go-github-com-containerd-console): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8b50b15ccb..77abde2575 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5841,6 +5841,30 @@  templates on ANSI compatible terminals.  You can create your own stylesheet or
 use one of our glamorous default themes.")
     (license license:expat)))
 
+(define-public go-github-com-containerd-console
+  (package
+    (name "go-github-com-containerd-console")
+    (version "1.0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/containerd/console")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0rxwgq578hphs2ldx1gg6c9fq1qm8rgqfx3vgi2sbrsmxn6m2438"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/containerd/console"))
+    (native-inputs
+     `(("go-golang-org-x-sys" ,go-golang-org-x-sys)))
+    (home-page "https://github.com/containerd/console")
+    (synopsis "Console package for Go")
+    (description "Golang package for dealing with consoles.  Light on
+dependencies and a simple API.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-coreos-go-semver
   (package
     (name "go-github-com-coreos-go-semver")