diff mbox series

[bug#48363,4/5] gnu: Add go-github-com-charmbracelet-bubbletea.

Message ID 20210511185554.67355-4-stefan@xsteve.at
State Accepted
Headers show
Series [bug#48362,1/5] gnu: go-github-com-muesli-reflow-wordwrap: Update to 0.2.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stefan Reichör May 11, 2021, 6:55 p.m. UTC
* gnu/packages/golang.scm (go-github-com-charmbracelet-bubbletea): New variable.
---
 gnu/packages/golang.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 77abde2575..a9f299be98 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5865,6 +5865,40 @@  use one of our glamorous default themes.")
 dependencies and a simple API.")
     (license license:asl2.0)))
 
+(define-public go-github-com-charmbracelet-bubbletea
+  (package
+    (name "go-github-com-charmbracelet-bubbletea")
+    (version "0.13.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/charmbracelet/bubbletea")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1105cggi5fwqx69m0vrhgwx6kaw82w4ahn58sj0a81603c4yvrk0"))))
+    (build-system go-build-system)
+    (native-inputs
+     `(("go-github-com-mattn-go-isatty" ,go-github-com-mattn-go-isatty)
+       ("go-github-com-containerd-console" ,go-github-com-containerd-console)
+       ("go-github-com-google-goterm" ,go-github-com-google-goterm)
+       ("go-github-com-mattn-go-isatty" ,go-github-com-mattn-go-isatty)
+       ("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)
+       ("go-github-com-muesli-reflow-ansi" ,go-github-com-muesli-reflow-ansi)
+       ("go-github-com-muesli-reflow-truncate" ,go-github-com-muesli-reflow-truncate)
+       ("go-github-com-muesli-termenv" ,go-github-com-muesli-termenv)
+       ("go-golang-org-colorful" ,go-golang-org-colorful)
+       ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)))
+    (arguments
+     `(#:import-path "github.com/charmbracelet/bubbletea"))
+    (home-page "https://github.com/charmbracelet/bubbletea")
+    (synopsis "A powerful Go TUI framework")
+    (description "A Go framework to build terminal apps. Bubble Tea is
+well-suited for simple and complex terminal applications, either inline,
+full-window, or a mix of both.")
+    (license license:expat)))
+
 (define-public go-github-com-coreos-go-semver
   (package
     (name "go-github-com-coreos-go-semver")