diff mbox series

[bug#47171,04/10] gnu: r-biobase: Move to (gnu packages bioconductor).

Message ID 20210315180904.8346-4-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Move some Bioconductor packages to (gnu packages bioconductor). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier March 15, 2021, 6:08 p.m. UTC
* gnu/packages/bioinformatics.scm (r-biobase): Move from here...
* gnu/packages/bioconductor.scm (r-biobase): ...to here.
---
 gnu/packages/bioconductor.scm   | 22 ++++++++++++++++++++++
 gnu/packages/bioinformatics.scm | 22 ----------------------
 2 files changed, 22 insertions(+), 22 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ec273cae70..b7308848c0 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1570,6 +1570,28 @@  microarrays.")
 databases.  Packages produced are intended to be used with AnnotationDbi.")
     (license license:artistic2.0)))
 
+(define-public r-biobase
+  (package
+    (name "r-biobase")
+    (version "2.50.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "Biobase" version))
+              (sha256
+               (base32
+                "11kgc4flywlm3i18603558l8ksv91c24vkc5fnnbcd375i2dhhd4"))))
+    (properties
+     `((upstream-name . "Biobase")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biocgenerics" ,r-biocgenerics)))
+    (home-page "https://bioconductor.org/packages/Biobase")
+    (synopsis "Base functions for Bioconductor")
+    (description
+     "This package provides functions that are needed by many other packages
+on Bioconductor or which replace R functions.")
+    (license license:artistic2.0)))
+
 (define-public r-category
   (package
     (name "r-category")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4889c148e4..b73862ff86 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7691,28 +7691,6 @@  including VCF header and contents in RDF and JSON.")
     (home-page "https://github.com/vcflib/bio-vcf")
     (license license:expat)))
 
-(define-public r-biobase
-  (package
-    (name "r-biobase")
-    (version "2.50.0")
-    (source (origin
-              (method url-fetch)
-              (uri (bioconductor-uri "Biobase" version))
-              (sha256
-               (base32
-                "11kgc4flywlm3i18603558l8ksv91c24vkc5fnnbcd375i2dhhd4"))))
-    (properties
-     `((upstream-name . "Biobase")))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-biocgenerics" ,r-biocgenerics)))
-    (home-page "https://bioconductor.org/packages/Biobase")
-    (synopsis "Base functions for Bioconductor")
-    (description
-     "This package provides functions that are needed by many other packages
-on Bioconductor or which replace R functions.")
-    (license license:artistic2.0)))
-
 (define-public r-annotationdbi
   (package
     (name "r-annotationdbi")