diff mbox series

[bug#44045,05/10] gnu: Add libCharon.

Message ID 20201017103547.13769-5-malte.f.gerdes@gmail.com
State Accepted
Headers show
Series WIP Ultimaker Cura | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Malte Frank Gerdes Oct. 17, 2020, 10:35 a.m. UTC
* gnu/packages/engineering.scm (libCharon): New variable.
---
 gnu/packages/engineering.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 1b4cb391b3..27d4eae948 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3009,3 +3009,27 @@  related Desktop Applications using PyQt5.  It belongs to the Cura project
 from Ultimaker.")
     (license license:lgpl3)))
 
+(define-public libCharon
+  (package
+    (name "libCharon")
+    (version "4.7.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+               (url "https://github.com/Ultimaker/libCharon")
+               (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1hcjbn29rlvy4xcscnnnyck91fg9cvnc73x50g1ir3y3l1gplc2k"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("pytest" ,python-pytest)))
+    (inputs
+     `(("python" ,python)))
+    (home-page "https://github.com/Ultimaker/libCharon")
+    (synopsis "File metadata and streaming library")
+    (description "libCharon is a python file metadata and streaming library.  It
+belongs to the Cura project from Ultimaker.")
+    (license license:lgpl3)))
+