diff mbox series

[bug#44045,09/10] gnu: Add python-pyinstrument.

Message ID 20201017103547.13769-9-malte.f.gerdes@gmail.com
State Accepted
Headers show
Series WIP Ultimaker Cura | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Malte Frank Gerdes Oct. 17, 2020, 10:35 a.m. UTC
* gnu/packages/python-check.scm (python-pyinstrument)@ New variable.
---
 gnu/packages/python-check.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 6d068a9cd8..4fcc382913 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -99,6 +99,28 @@  nosetests, etc...) in Python projects.")
   (description "A CPython extension supporting pyinstrument")
   (license license:bsd-3)))
 
+(define-public python-pyinstrument
+  (package
+    (name "python-pyinstrument")
+    (version "3.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pyinstrument" version))
+       (sha256
+        (base32
+         "0r8n2ajhjx9mlsy7hsvf6ihw1lk4zn1l95vd1c3g0jc3m1pfz3yf"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-pyinstrument-cext" ,python-pyinstrument-cext)))
+    (home-page
+     "https://github.com/joerick/pyinstrument")
+    (synopsis
+     "Call stack profiler for Python. Shows you why your code is slow!")
+    (description
+     "Call stack profiler for Python. Shows you why your code is slow!")
+    (license license:bsd-3)))
+
 (define-public python-vcrpy
   (package
     (name "python-vcrpy")