diff mbox series

[bug#44045,10/10] gnu: Add python-trimesh.

Message ID 20201017103547.13769-10-malte.f.gerdes@gmail.com
State Accepted
Headers show
Series WIP Ultimaker Cura | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Malte Frank Gerdes Oct. 17, 2020, 10:35 a.m. UTC
* gnu/packages/python-science.scm (python-trimesh): New variable.
---
 gnu/packages/python-science.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 101c8fb640..1d5835bff5 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -10,6 +10,7 @@ 
 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -35,6 +36,7 @@ 
   #:use-module (gnu packages maths)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-check)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages sphinx)
@@ -285,6 +287,33 @@  logic, also known as grey logic.")
 of the SGP4 satellite tracking algorithm.")
     (license license:expat)))
 
+(define-public python-trimesh
+  (package
+  (name "python-trimesh")
+  (version "3.8.10")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (pypi-uri "trimesh" version))
+      (sha256
+        (base32
+          "0sf0wms2zhyljhiqjmyp77kx7b123gmr98hmna0y2ic7idzhzyr4"))))
+  (build-system python-build-system)
+  (propagated-inputs
+    `(("python-numpy" ,python-numpy)
+      ("python-setuptools" ,python-setuptools)))
+  (native-inputs
+    `(("python-coveralls" ,python-coveralls)
+      ("python-pyinstrument" ,python-pyinstrument)
+      ("python-pytest" ,python-pytest)
+      ("python-pytest-cov" ,python-pytest-cov)))
+  (home-page "https://github.com/mikedh/trimesh")
+  (synopsis
+    "Import, export, process, analyze and view triangular meshes.")
+  (description
+    "Import, export, process, analyze and view triangular meshes.")
+  (license license:expat)))
+
 (define-public python-pandas
   (package
     (name "python-pandas")