diff mbox series

[bug#43745,25/27] gnu: ocaml-jane-street-headers: Build only with OCaml 4.07.

Message ID 20201001134133.32105-25-julien@lepiller.eu
State Accepted
Headers show
Series [bug#43745,01/27] gnu: unison: Build with ocaml-4.09. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller Oct. 1, 2020, 1:41 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-jane-street-headers): Rename to...
(ocaml4.07-jane-street-headers): ...to this.  Use OCaml 4.07.
---
 gnu/packages/ocaml.scm | 12 +++++++-----
 1 file changed, 7 insertions(+), 5 deletions(-)

Comments

Simon Tournier Oct. 13, 2020, 11:46 a.m. UTC | #1
On Thu, 01 Oct 2020 at 15:41, Julien Lepiller <julien@lepiller.eu> wrote:
> * gnu/packages/ocaml.scm (ocaml-jane-street-headers): Rename to...
> (ocaml4.07-jane-street-headers): ...to this.  Use OCaml 4.07.

>      (arguments
> -     `(#:test-target "."))
> +     `(#:test-target "."
> +       #:ocaml ,ocaml-4.07
> +       #:findlib ,ocaml4.07-findlib
> +       #:dune ,ocaml4.07-dune))

Maybe this is missing in the commit message.

Otherwsie LGTM.


All the best,
simon
Julien Lepiller Oct. 13, 2020, 11:51 a.m. UTC | #2
Well, I'd say it's included in "build with ocaml 4.07", no?

Le 13 octobre 2020 07:46:31 GMT-04:00, zimoun <zimon.toutoune@gmail.com> a écrit :
>
>On Thu, 01 Oct 2020 at 15:41, Julien Lepiller <julien@lepiller.eu>
>wrote:
>> * gnu/packages/ocaml.scm (ocaml-jane-street-headers): Rename to...
>> (ocaml4.07-jane-street-headers): ...to this.  Use OCaml 4.07.
>
>>      (arguments
>> -     `(#:test-target "."))
>> +     `(#:test-target "."
>> +       #:ocaml ,ocaml-4.07
>> +       #:findlib ,ocaml4.07-findlib
>> +       #:dune ,ocaml4.07-dune))
>
>Maybe this is missing in the commit message.
>
>Otherwsie LGTM.
>
>
>All the best,
>simon
Simon Tournier Oct. 13, 2020, 3:13 p.m. UTC | #3
On Tue, 13 Oct 2020 at 16:46, Julien Lepiller <julien@lepiller.eu> wrote:
>
> Well, I'd say it's included in "build with ocaml 4.07", no?

Maybe, I do not know. :-)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 96ef6fbd17..1a08bc9531 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5182,9 +5182,9 @@  This library implements a splittable pseudo-random number generator that sacrifi
 cryptographic-quality randomness in favor of performance.")
     (license license:asl2.0)))
 
-(define-public ocaml-jane-street-headers
+(define-public ocaml4.07-jane-street-headers
   (package
-    (name "ocaml-jane-street-headers")
+    (name "ocaml4.07-jane-street-headers")
     (version "0.11.0")
     (source (origin
               (method url-fetch)
@@ -5196,7 +5196,10 @@  cryptographic-quality randomness in favor of performance.")
                 "0afhzm08l9v883fhpqqh2lmy7az609pxif40bp7x1sk8c0yszqsh"))))
     (build-system dune-build-system)
     (arguments
-     `(#:test-target "."))
+     `(#:test-target "."
+       #:ocaml ,ocaml-4.07
+       #:findlib ,ocaml4.07-findlib
+       #:dune ,ocaml4.07-dune))
     (home-page "https://github.com/janestreet/jane-street-headers")
     (synopsis "Jane Street C header files")
     (description "This package provides C header files shared between the
@@ -5350,8 +5353,7 @@  standard library that was developed by Jane Street.")
         ("ocaml-bin-prot" ,ocaml4.07-bin-prot)
         ("ocaml-configurator" ,ocaml4.07-configurator)
         ("ocaml-fieldslib" ,ocaml4.07-fieldslib)
-        ("ocaml-jane-street-headers"
-         ,(package-with-ocaml4.07 ocaml-jane-street-headers))
+        ("ocaml-jane-street-headers" ,ocaml4.07-jane-street-headers)
         ("ocaml-ppx-assert" ,ocaml4.07-ppx-assert)
         ("ocaml-ppx-base" ,ocaml4.07-ppx-base)
         ("ocaml-ppx-hash" ,ocaml4.07-ppx-hash)