diff mbox series

[bug#43745,16/27] gnu: Add ocaml-stdlib-shims.

Message ID 20201001134133.32105-16-julien@lepiller.eu
State Accepted
Headers show
Series [bug#43745,01/27] gnu: unison: Build with ocaml-4.09. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller Oct. 1, 2020, 1:41 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-stdlib-shims): New variable.
---
 gnu/packages/ocaml.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Simon Tournier Oct. 12, 2020, 11:40 p.m. UTC | #1
On Thu, 01 Oct 2020 at 15:41, Julien Lepiller <julien@lepiller.eu> wrote:
> * gnu/packages/ocaml.scm (ocaml-stdlib-shims): New variable.
> ---
>  gnu/packages/ocaml.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index aa9230cd9e..7f402e0a47 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -265,6 +265,30 @@ functional, imperative and object-oriented styles of programming.")
>  for building OCaml library and programs.")
>      (license license:lgpl2.1+)))
>  
> +(define-public ocaml-stdlib-shims
> +  (package
> +    (name "ocaml-stdlib-shims")
> +    (version "0.1.0")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                     (url "https://github.com/ocaml/stdlib-shims")
> +                     (commit version)))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "1jv6yb47f66239m7hsz7zzw3i48mjpbvfgpszws48apqx63wjwsk"))))
> +    (build-system dune-build-system)
> +    (home-page "https://github.com/ocaml/stdlib-shims")
> +    (synopsis "Backport of some of the new stdlib features to older OCaml")
> +    (description "This package backports some of the new stdlib features to
> +older OCaml compiler, such as the Stdlib module.
> +
> +This allows projects that require compatibility with older compilers to
> +use these new features in their code.")
> +    ;; Same as the OCaml compiler
> +    (license (list license:qpl license:lgpl2.0))))
> +
>  (define-public ocaml-extlib
>    (package
>      (name "ocaml-extlib")

Already defined and substitute available.  You can drop this commit.


--8<---------------cut here---------------start------------->8---
    (synopsis "Simple implementation of expect")
    (description "Help building unitary testing of interactive program.  You
can match the question using a regular expression or a timeout.")
    (license license:lgpl2.1+))) ; with the OCaml static compilation exception

(define-public ocaml-stdlib-shims
  (package
    (name "ocaml-stdlib-shims")
    (version "0.1.0")
    (source (origin
              (method git-fetch)
              (uri (git-reference
                     (url "https://github.com/ocaml/stdlib-shims")
                     (commit version)))
              (file-name (git-file-name name version))
              (sha256
               (base32
                "007dwywsr5285z0np6a9nr0h8iqmyzfrlx6s5xaqcwj69zabsrjm"))))
    (build-system dune-build-system)
    (home-page "https://github.com/ocaml/stdlib-shims")
    (synopsis "OCaml stdlib features backport to older OCaml compilers")
    (description "This package backports some of the new stdlib features to
older compilers, such as the Stdlib module.  This allows projects that require
compatibility with older compiler to use these new features in their code.")
    ;; with ocaml-linking exception
    (license license:lgpl2.1+)))

(define-public ocaml-fileutils
  (package
    (name "ocaml-fileutils")
--8<---------------cut here---------------end--------------->8---
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index aa9230cd9e..7f402e0a47 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -265,6 +265,30 @@  functional, imperative and object-oriented styles of programming.")
 for building OCaml library and programs.")
     (license license:lgpl2.1+)))
 
+(define-public ocaml-stdlib-shims
+  (package
+    (name "ocaml-stdlib-shims")
+    (version "0.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/ocaml/stdlib-shims")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1jv6yb47f66239m7hsz7zzw3i48mjpbvfgpszws48apqx63wjwsk"))))
+    (build-system dune-build-system)
+    (home-page "https://github.com/ocaml/stdlib-shims")
+    (synopsis "Backport of some of the new stdlib features to older OCaml")
+    (description "This package backports some of the new stdlib features to
+older OCaml compiler, such as the Stdlib module.
+
+This allows projects that require compatibility with older compilers to
+use these new features in their code.")
+    ;; Same as the OCaml compiler
+    (license (list license:qpl license:lgpl2.0))))
+
 (define-public ocaml-extlib
   (package
     (name "ocaml-extlib")