diff mbox series

[bug#43745,21/27] gnu: ocaml-alcotest: Update to 1.0.0.

Message ID 20201001134133.32105-21-julien@lepiller.eu
State Accepted
Headers show
Series [bug#43745,01/27] gnu: unison: Build with ocaml-4.09. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller Oct. 1, 2020, 1:41 p.m. UTC
---
 gnu/packages/ocaml.scm | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

Comments

Simon Tournier Oct. 13, 2020, 11:22 a.m. UTC | #1
On Thu, 01 Oct 2020 at 15:41, Julien Lepiller <julien@lepiller.eu> wrote:
> ---
>  gnu/packages/ocaml.scm | 10 ++++++----
>  1 file changed, 6 insertions(+), 4 deletions(-)

Missing:

 * gnu/packages/ocaml.scm (ocaml-alcotest): Update to 1.0.0.
 and the other modif


BTW,

--8<---------------cut here---------------start------------->8---
guix build: error: derivation `/gnu/store/2d4wz8ax8f2s3a1g9clcskas7mn07clb-ocaml-alcotest-1.0.0.drv' may not be deterministic: output `/gnu/store/d4z21drbyn5sgsvfmkil0qlpd8zrwxbx-ocaml-alcotest-1.0.0' differs
--8<---------------cut here---------------end--------------->8---

All the best,
simon
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 365c87d8b2..9633dc30fb 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1683,14 +1683,14 @@  immutability.")
 (define-public ocaml-alcotest
   (package
     (name "ocaml-alcotest")
-    (version "0.8.5")
+    (version "1.0.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/mirage/alcotest/releases/"
                                   "download/" version "/alcotest-" version ".tbz"))
               (sha256
                 (base32
-                  "0szwjxvaahgynsx0apj81jxj3ki6yz4is9mh2wkcbx66qy7n6fvb"))))
+                  "1a43ilhwnj58pq3bi78ni46l9wh6klmmgfc93i94mvyx48bzzayx"))))
     (build-system dune-build-system)
     (arguments
      `(#:package "alcotest"
@@ -1701,8 +1701,10 @@  immutability.")
      `(("ocaml-astring" ,ocaml-astring)
        ("ocaml-cmdliner" ,ocaml-cmdliner)
        ("ocaml-fmt" ,ocaml-fmt)
-       ("ocaml-result" ,ocaml-result)
-       ("ocaml-uuidm" ,ocaml-uuidm)))
+       ("ocaml-re" ,ocaml-re)
+       ("ocaml-stdlib-shims" ,ocaml-stdlib-shims)
+       ("ocaml-uuidm" ,ocaml-uuidm)
+       ("ocaml-uutf" ,ocaml-uutf)))
     (home-page "https://github.com/mirage/alcotest")
     (synopsis "Lightweight OCaml test framework")
     (description "Alcotest exposes simple interface to perform unit tests.  It