diff mbox series

[bug#42069,v2,6/6] gnu: Add python-pytest-mpl.

Message ID 20200723182328.49525-6-monego@posteo.net
State Accepted
Headers show
Series [bug#42069,v2,1/6] gnu: Add python-pytest-arraydiff. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Vinicius Monego July 23, 2020, 6:23 p.m. UTC
* gnu/packages/python-check.scm (python-pytest-mpl): New variable.
---
 gnu/packages/python-check.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 507d9cf468..617e474bf0 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -282,6 +282,35 @@  developers to control unit tests that require access to data from the
 internet.")
     (license license:bsd-3)))
 
+(define-public python-pytest-mpl
+  (package
+    (name "python-pytest-mpl")
+    (version "0.11")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-mpl" version))
+       (sha256
+        (base32 "1km202c1s5kcn52fx0266p06qb34va3warcby594dh6vixxa9i96"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "pytest" "-vv"))))))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))
+    (propagated-inputs
+     `(("python-matplotlib" ,python-matplotlib)
+       ("python-pillow" ,python-pillow)))
+    (home-page "https://github.com/matplotlib/pytest-mpl")
+    (synopsis "Pytest plugin to help with testing figures output from Matplotlib")
+    (description
+     "This is a plugin to facilitate image comparison for Matplotlib figures
+in Pytest.")
+    (license license:bsd-3)))
+
 (define-public python-pytest-vcr
   (package
     (name "python-pytest-vcr")