diff mbox series

[bug#42069,v2,5/6] gnu: Add python-pytest-remotedata.

Message ID 20200723182328.49525-5-monego@posteo.net
State Accepted
Headers show
Series [bug#42069,v2,1/6] gnu: Add python-pytest-arraydiff. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Vinicius Monego July 23, 2020, 6:23 p.m. UTC
* gnu/packages/python-check.scm (python-pytest-remotedata): New variable.
---
 gnu/packages/python-check.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Marius Bakke July 25, 2020, 4:29 p.m. UTC | #1
Vinicius Monego <monego@posteo.net> writes:

> * gnu/packages/python-check.scm (python-pytest-remotedata): New variable.

[...]
  
> +(define-public python-pytest-remotedata
> +  (package
> +    (name "python-pytest-remotedata")
> +    (version "0.3.2")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "pytest-remotedata" version))
> +       (sha256
> +        (base32 "1h6g6shib6z07azf12rnsa053470ggbd7hy3bnbw8nf3nza5h372"))))
> +    (build-system python-build-system)
> +    (arguments
> +     '(#:phases
> +       (modify-phases %standard-phases
> +         (replace 'check
> +           (lambda* (#:key inputs outputs #:allow-other-keys)
> +             ;; Make ;TODO: he installed plugin discoverable by Pytest.

I removed the stray TODO and committed.  Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index de8cb09c48..507d9cf468 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -247,6 +247,41 @@  developers to detect whether any file handles or other file-like objects
 were inadvertently left open at the end of a unit test.")
     (license license:bsd-3)))
 
+(define-public python-pytest-remotedata
+  (package
+    (name "python-pytest-remotedata")
+    (version "0.3.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-remotedata" version))
+       (sha256
+        (base32 "1h6g6shib6z07azf12rnsa053470ggbd7hy3bnbw8nf3nza5h372"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             ;; Make ;TODO: he installed plugin discoverable by Pytest.
+             (add-installed-pythonpath inputs outputs)
+             (invoke "pytest" "-vv" "-k"
+                     (string-append
+                      ;; These tests require internet access. Disable them.
+                      "not test_default_behavior"
+                      " and not test_strict_with_decorator")))))))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))
+    (propagated-inputs
+     `(("python-six" ,python-six)))
+    (home-page "https://github.com/astropy/pytest-remotedata")
+    (synopsis "Pytest plugin for controlling remote data access")
+    (description
+     "This package provides a plugin for the Pytest framework that allows
+developers to control unit tests that require access to data from the
+internet.")
+    (license license:bsd-3)))
+
 (define-public python-pytest-vcr
   (package
     (name "python-pytest-vcr")