diff mbox series

[bug#42069,v2,1/6] gnu: Add python-pytest-arraydiff.

Message ID 20200723182328.49525-1-monego@posteo.net
State Accepted
Headers show
Series [bug#42069,v2,1/6] gnu: Add python-pytest-arraydiff. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Vinicius Monego July 23, 2020, 6:23 p.m. UTC
* gnu/packages/python-check.scm (python-pytest-arraydiff): New variable.
---
 gnu/packages/python-check.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Marius Bakke July 25, 2020, 4:24 p.m. UTC | #1
Vinicius Monego <monego@posteo.net> writes:

> * gnu/packages/python-check.scm (python-pytest-arraydiff): New variable.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 200bce6ced..bc0da40cbd 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
+;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -125,6 +126,32 @@  detect the absence of a cassette file and once again record all HTTP
 interactions, which will update them to correspond to the new API.")
     (license license:expat)))
 
+(define-public python-pytest-arraydiff
+  (package
+    (name "python-pytest-arraydiff")
+    (version "0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-arraydiff" version))
+       (sha256
+        (base32 "05bcvhh2ycxa35znl8b3l9vkcmx7vwm5c3fpakbpw46c7vsn4bfy"))))
+    (build-system python-build-system)
+    (arguments
+     ;; Tests require python-astropy, which itself requires this package.
+     ;; Disable tests to avoid the circular dependency problem.
+     '(#:tests? #f))
+    (propagated-inputs
+     `(("python-numpy" ,python-numpy)
+       ("python-six" ,python-six)))
+    (home-page "https://github.com/astropy/pytest-arraydiff")
+    (synopsis "Pytest plugin to help with comparing array output from tests")
+    (description
+     "This is a py.test plugin to facilitate the generation and comparison of
+data arrays produced during tests, in particular in cases where the arrays
+are too large to conveniently hard-code them in the tests.")
+    (license license:bsd-3)))
+
 (define-public python-pytest-vcr
   (package
     (name "python-pytest-vcr")