diff mbox series

[bug#42073,5/6] gnu: Add python-pytest-remotedata.

Message ID 20200626221542.22604-5-monego@posteo.net
State Accepted
Headers show
Series [bug#42069,1/6] gnu: Add python-pytest-arraydiff. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Vinicius Monego June 26, 2020, 10:15 p.m. UTC
* gnu/packages/check.scm (python-pytest-remotedata): New variable.
---
 gnu/packages/check.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 136bdcc6d2..5ed5675998 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2199,6 +2199,40 @@  pytest report.")
 (define-public python2-pytest-capturelog
   (package-with-python2 python-pytest-capturelog))
 
+(define-public python-pytest-remotedata
+  (package
+    (name "python-pytest-remotedata")
+    (version "0.3.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-remotedata" version))
+       (sha256
+        (base32 "1h6g6shib6z07azf12rnsa053470ggbd7hy3bnbw8nf3nza5h372"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             ;; Make the installed plugin discoverable by Pytest.
+             (add-installed-pythonpath inputs outputs)
+             (invoke "pytest" "-vv" "-k"
+                     (string-append
+                      ;; These tests require internet access. Disable them.
+                      "not test_default_behavior"
+                      " and not test_strict_with_decorator")))))))
+    (propagated-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-six" ,python-six)))
+    (home-page "https://github.com/astropy/pytest-remotedata")
+    (synopsis "Pytest plugin for controlling remote data access")
+    (description
+     "This package provides a plugin for the Pytest framework that allows
+developers to control unit tests that require access to data from the
+internet.")
+    (license license:bsd-3)))
+
 (define-public python-pytest-catchlog
   (package
     (name "python-pytest-catchlog")