diff mbox series

[bug#42071,2/6] gnu: Add python-pytest-doctestplus.

Message ID 20200626221542.22604-2-monego@posteo.net
State Accepted
Headers show
Series [bug#42069,1/6] gnu: Add python-pytest-arraydiff. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Vinicius Monego June 26, 2020, 10:15 p.m. UTC
* gnu/packages/check.scm (python-pytest-doctestplus): New variable.
---
 gnu/packages/check.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index ccf74cfb46..6b682d18a2 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1196,6 +1196,34 @@  subprocess and see the output as well as any file modifications.")
 (define-public python2-testtools-bootstrap
   (package-with-python2 python-testtools-bootstrap))
 
+(define-public python-pytest-doctestplus
+  (package
+    (name "python-pytest-doctestplus")
+    (version "0.7.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-doctestplus" version))
+       (sha256
+        (base32 "1ai9kvd7xbq2jg2h8gmkb8lqzyrxvdh4zg3vxndg149iwd1hyi7d"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             ;; Make the installed plugin discoverable by Pytest.
+             (add-installed-pythonpath inputs outputs)
+             (invoke "pytest" "-vv"))))))
+    (propagated-inputs
+     `(("python-pytest" ,python-pytest)))
+    (home-page "https://github.com/astropy/pytest-doctestplus")
+    (synopsis "Pytest plugin with advanced doctest features")
+    (description
+     "This package contains a plugin for the Pytest framework that provides
+advanced doctest support and enables the testing of reStructuredText files.")
+    (license license:bsd-3)))
+
 (define-public python-testtools
   (package
     (inherit python-testtools-bootstrap)