diff mbox series

[bug#42069,1/6] gnu: Add python-pytest-arraydiff.

Message ID 20200626221542.22604-1-monego@posteo.net
State Accepted
Headers show
Series [bug#42069,1/6] gnu: Add python-pytest-arraydiff. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Vinicius Monego June 26, 2020, 10:15 p.m. UTC
* gnu/packages/check.scm (python-pytest-arraydiff): New variable.
---
 gnu/packages/check.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Nicolas Goaziou July 7, 2020, 12:30 p.m. UTC | #1
Hello,

Vinicius Monego <monego@posteo.net> writes:

> * gnu/packages/check.scm (python-pytest-arraydiff): New variable.

Would it make sense to add all the python-pytest-* stuff to
"python-check.scm" instead of "check.scm"?

Regards,
Brett Gilio July 25, 2020, 2:20 a.m. UTC | #2
merge 42069 42070 42071 42072 42073 42074
Marius Bakke July 25, 2020, 4:29 p.m. UTC | #3
Brett Gilio <brettg@gnu.org> writes:

> merge 42069 42070 42071 42072 42073 42074

Applied the whole series, thank you Vinicius!
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index df9d380f71..ccf74cfb46 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1750,6 +1750,33 @@  look and feel of py.test, using a progress bar and showing failures and errors
 instantly.")
     (license license:bsd-3)))
 
+(define-public python-pytest-arraydiff
+  (package
+    (name "python-pytest-arraydiff")
+    (version "0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-arraydiff" version))
+       (sha256
+        (base32 "05bcvhh2ycxa35znl8b3l9vkcmx7vwm5c3fpakbpw46c7vsn4bfy"))))
+    (build-system python-build-system)
+    (arguments
+     ;; Tests require python-astropy, which itself requires this package.
+     ;; Disable tests to avoid the circular dependency problem.
+     '(#:tests? #f))
+    (propagated-inputs
+     `(("python-numpy" ,python-numpy)
+       ("python-pytest" ,python-pytest)
+       ("python-six" ,python-six)))
+    (home-page "https://github.com/astropy/pytest-arraydiff")
+    (synopsis "Pytest plugin to help with comparing array output from tests")
+    (description
+     "This is a py.test plugin to facilitate the generation and comparison of
+data arrays produced during tests, in particular in cases where the arrays
+are too large to conveniently hard-code them in the tests.")
+    (license license:bsd-3)))
+
 (define-public python-hypothesis
   (package
     (name "python-hypothesis")