diff mbox series

[bug#41193,07/13] gnu: libnma: Update inputs and licenses.

Message ID 20200511190046.27155-7-brice@waegenei.re
State Accepted
Headers show
Series Update network-manager suite | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Brice Waegeneire May 11, 2020, 7 p.m. UTC
* gnu/packages/gnome.scm (libnam)[arguments]: Remove 'glib-or-gtk?' and
add phase 'patch-docbook-xml'.
[native-inputs]: Add 'docboock-xml-4.3' and 'vala'.
[inputs]: Remove 'adwaita'icon-theme'.
[license]: Add 'lgpl2.1+'.
---
 gnu/packages/gnome.scm | 24 +++++++++++++++++-------
 1 file changed, 17 insertions(+), 7 deletions(-)

Comments

Leo Famulari May 11, 2020, 8 p.m. UTC | #1
On Mon, May 11, 2020 at 09:00:40PM +0200, Brice Waegeneire wrote:
>     ;; Some files carry the "GPL-2.0+" SPDX identifier while others say
>     ;; "LGPL-2.1+".
> -   (license license:gpl2+)))
> +   (license (list license:gpl2+
> +                   license:lgpl2.1+))))

Watch the indentation here. However, in general, it's enough to list the
license that the entire package is distributed under. Without taking a
closer look, I'd guess it's GPL2+.
Brice Waegeneire May 12, 2020, 9:18 p.m. UTC | #2
On 2020-05-11 20:00, Leo Famulari wrote:
> On Mon, May 11, 2020 at 09:00:40PM +0200, Brice Waegeneire wrote:
>>     ;; Some files carry the "GPL-2.0+" SPDX identifier while others 
>> say
>>     ;; "LGPL-2.1+".
>> -   (license license:gpl2+)))
>> +   (license (list license:gpl2+
>> +                   license:lgpl2.1+))))
> 
> Watch the indentation here. However, in general, it's enough to list 
> the
> license that the entire package is distributed under. Without taking a
> closer look, I'd guess it's GPL2+.

You're right it's mostly GPL2+, dropped that part.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index fd2a1506f4..251c4d89cd 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -818,16 +818,26 @@  client devices can handle.")
               "09mp6k0hfam1vyyv9kcd8j4gb2r58i05ipx2nswb58ris599bxja"))))
    (build-system meson-build-system)
    (arguments
-    `(#:glib-or-gtk? #t))
+    `(#:phases
+      (modify-phases %standard-phases
+        (add-after 'unpack 'patch-docbook-xml
+          (lambda* (#:key inputs #:allow-other-keys)
+            (let ((xmldoc (string-append (assoc-ref inputs "docbook-xml")
+                                         "/xml/dtd/docbook")))
+              (substitute* "libnma-docs.xml"
+                (("http://.*/docbookx\\.dtd")
+                 (string-append xmldoc "/docbookx.dtd")))
+              #t))))))
    (native-inputs
-    `(("gettext" ,gettext-minimal)
+    `(("docbook-xml" ,docbook-xml-4.3)
+      ("gettext" ,gettext-minimal)
       ("glib:bin" ,glib "bin")
       ("gtk-doc" ,gtk-doc)
       ("gobject-introspection" ,gobject-introspection)
-      ("pkg-config" ,pkg-config)))
+      ("pkg-config" ,pkg-config)
+      ("vala" ,vala)))
    (inputs
-    `(("adwaita-icon-theme" ,adwaita-icon-theme)
-      ("gcr" ,gcr)
+    `(("gcr" ,gcr)
       ("gtk+" ,gtk+)
       ("iso-codes" ,iso-codes)
       ("mobile-broadband-provider-info" ,mobile-broadband-provider-info)
@@ -837,10 +847,10 @@  client devices can handle.")
 initially part of network-manager-applet and has now become a separate
 project.")
    (home-page "https://gitlab.gnome.org/GNOME/libnma")
-
    ;; Some files carry the "GPL-2.0+" SPDX identifier while others say
    ;; "LGPL-2.1+".
-   (license license:gpl2+)))
+   (license (list license:gpl2+
+                   license:lgpl2.1+))))
 
 (define-public gnome-menus
   (package