diff mbox series

[bug#41193,02/13] gnu: network-manager: Add iwd support.

Message ID 20200511190046.27155-2-brice@waegenei.re
State Accepted
Headers show
Series Update network-manager suite | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Brice Waegeneire May 11, 2020, 7 p.m. UTC
---
 gnu/packages/gnome.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 04bd6e31d5..39909559cf 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6366,7 +6366,9 @@  users.")
                "--with-suspend-resume=elogind"
                "--with-consolekit=no"
                "--with-crypto=gnutls"
-               "--disable-config-plugin-ibft"
+               "--with-iwd=yes"
+               "--with-libaudit=yes"
+               "--with-resolvconf=yes"
                "--sysconfdir=/etc"
                "--localstatedir=/var"
                (string-append "--with-udev-dir="
@@ -6420,10 +6422,6 @@  users.")
            (lambda _
              ;; For the missing /etc/machine-id.
              (setenv "DBUS_FATAL_WARNINGS" "0")
-
-             ;; XXX: Regenerate some of the tests that are dependent on Python version.
-             ;; Try removing this variable for newer versions of NetworkManager.
-             (setenv "NM_TEST_REGENERATE" "1")
              #t))
          (replace 'install
            (lambda _
@@ -6458,7 +6456,9 @@  users.")
        ("gnutls" ,gnutls)
        ("iptables" ,iptables)
        ("isc-dhcp" ,isc-dhcp)
+       ("iwd" ,iwd)                     ; wpa_supplicant alternative
        ("jansson" ,jansson)
+       ("libaudit" ,audit)
        ("libgcrypt" ,libgcrypt)
        ("libgudev" ,libgudev)
        ("libndp" ,libndp)
@@ -6466,6 +6466,7 @@  users.")
        ("libsoup" ,libsoup)
        ("modem-manager" ,modem-manager)
        ("newt" ,newt)                       ;for the 'nmtui' console interface
+       ("openresolv" ,openresolv)           ; alternative resolv.conf manager
        ("polkit" ,polkit)
        ("ppp" ,ppp)
        ("readline" ,readline)