diff mbox series

[bug#41167,5/5] gnu: Add julia-compat.

Message ID 20200510081513.26015-5-nicolo@nixo.xyz
State Accepted
Headers show
Series [bug#41167,1/5] gnu: julia: Fix patch url. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Nicolò Balzarotti May 10, 2020, 8:15 a.m. UTC
* julia-xyz.scm: New file.
* local.mk: Add julia-xyz.scm to it.
* julia-xyz.scm (julia-compat): New variable.
---
 gnu/local.mk               |  1 +
 gnu/packages/julia-xyz.scm | 27 +++++++++++++++++++++++++++
 2 files changed, 28 insertions(+)
 create mode 100644 gnu/packages/julia-xyz.scm

Comments

Ludovic Courtès May 11, 2020, 8:58 p.m. UTC | #1
Hello!

nixo <anothersms@gmail.com> skribis:

> * julia-xyz.scm: New file.
> * local.mk: Add julia-xyz.scm to it.
> * julia-xyz.scm (julia-compat): New variable.

Please spell out file names; you can also remove the last line, not
needed here since it’s a new file.

> --- /dev/null
> +++ b/gnu/packages/julia-xyz.scm
> @@ -0,0 +1,27 @@
> +(define-module (gnu packages julia-xyz)

Could you add the license/copyright header and resend this one?

I’ll see if I can apply the whole series and build it tomorrow.

Thank you!

Ludo’.
Ludovic Courtès May 11, 2020, 9:06 p.m. UTC | #2
Hello!

nixo <anothersms@gmail.com> skribis:

> * julia-xyz.scm: New file.
> * local.mk: Add julia-xyz.scm to it.
> * julia-xyz.scm (julia-compat): New variable.

Please spell out file names; you can also remove the last line, not
needed here since it’s a new file.

> --- /dev/null
> +++ b/gnu/packages/julia-xyz.scm
> @@ -0,0 +1,27 @@
> +(define-module (gnu packages julia-xyz)

Could you add the license/copyright header and resend this one?

I’ll see if I can apply the whole series and build it tomorrow.

Thank you!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index a7ccec5e0b..9df42e47fe 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -291,6 +291,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/jrnl.scm				\
   %D%/packages/jose.scm				\
   %D%/packages/julia.scm			\
+  %D%/packages/julia-xyz.scm			\
   %D%/packages/jupyter.scm			\
   %D%/packages/kawa.scm				\
   %D%/packages/kde.scm				\
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
new file mode 100644
index 0000000000..b96df408ef
--- /dev/null
+++ b/gnu/packages/julia-xyz.scm
@@ -0,0 +1,27 @@ 
+(define-module (gnu packages julia-xyz)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix git-download)
+  #:use-module (guix build-system julia))
+
+(define-public julia-compat
+  (package
+    (name "julia-compat")
+    (version "3.9.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaLang/Compat.jl")
+             (commit (string-append "v" version))))
+       (file-name "Compat")
+       (sha256
+        (base32 "01vwjr2134bzgnaxwd67knbibbhnfgnqjw7gxrp29s6y2a6j3882"))))
+    (build-system julia-build-system)
+    (home-page "https://github.com/JuliaLang/Compat.jl")
+    (synopsis "Compatibility across Julia versions")
+    (description "The Compat package is designed to ease interoperability
+between older and newer versions of the Julia language.  The Compat package
+provides a macro that lets you use the latest syntax in a backwards-compatible
+way.")
+    (license license:expat)))