diff mbox series

[bug#40391,3/6] gnu: gdb: Make some inputs native.

Message ID 20200402191533.7517-3-vincent.legoll@gmail.com
State Accepted
Headers show
Series Make some more inputs native. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Vincent Legoll April 2, 2020, 7:15 p.m. UTC
* gnu/packages/gdb.scm (gdb)[inputs]: Move dejagnu from here...
[native-inputs]: ...to here.
---
 gnu/packages/gdb.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 01f93f6def..c3f071965a 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2015, 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -94,7 +95,6 @@ 
        ("guile" ,guile-2.0)
        ("python" ,python)
        ("python-wrapper" ,python-wrapper)
-       ("dejagnu" ,dejagnu)
        ("source-highlight" ,source-highlight)
 
        ;; Allow use of XML-formatted syscall information.  This enables 'catch
@@ -102,6 +102,7 @@ 
        ("libxml2" ,libxml2)))
     (native-inputs
       `(("texinfo" ,texinfo)
+       ("dejagnu" ,dejagnu)
         ("pkg-config" ,pkg-config)))
     (home-page "https://www.gnu.org/software/gdb/")
     (synopsis "The GNU debugger")