diff mbox series

[bug#39086,5/5] gnu: ibus: Disable parallel build.

Message ID 20200111120829.29821-5-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#39086,1/5] licenses: Add Unicode license. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Leo Prikler Jan. 11, 2020, 12:08 p.m. UTC
* gnu/packages/ibus (arguments): Disable parallel build.
---
 gnu/packages/ibus.scm | 3 +++
 1 file changed, 3 insertions(+)

Comments

Ricardo Wurmus Jan. 16, 2020, 9:13 p.m. UTC | #1
Leo Prikler <leo.prikler@student.tugraz.at> writes:

> * gnu/packages/ibus (arguments): Disable parallel build.

This should be:

    * gnu/packages/ibus.scm (ibus)[arguments]: Disable parallel build.

Hint: if you’re using Emacs with Magit and Yasnippets you can cut down
on a few of these commit message errors (in simple cases).  The snippets
are not very helpful in this particular case, but at least they get the
file name right ;)

>      (arguments
>       `(#:tests? #f  ; tests fail because there's no connection to dbus
> +       ;; Parallel build would fail after I added Emoji support.  This appears
> +       ;; to be a race condition, but I'm unsure what exactly triggers it.
> +       #:parallel-build? #f

Please don’t use “I” because it isn’t obvious from the context who is
speaking.  It’s better to keep it short and impersonal.
diff mbox series

Patch

diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index 66cfb10068..2d60173c6b 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -161,6 +161,9 @@  conventions.")
     (build-system glib-or-gtk-build-system)
     (arguments
      `(#:tests? #f  ; tests fail because there's no connection to dbus
+       ;; Parallel build would fail after I added Emoji support.  This appears
+       ;; to be a race condition, but I'm unsure what exactly triggers it.
+       #:parallel-build? #f
        #:configure-flags `("--enable-python-library"
                            ,(string-append
                              "--with-unicode-emoji-dir="