diff mbox series

[bug#39086,4/5] gnu: ibus: Build with emoji support.

Message ID 20200111120829.29821-4-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#39086,1/5] licenses: Add Unicode license. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Leo Prikler Jan. 11, 2020, 12:08 p.m. UTC
* gnu/packages/ibus.scm (ibus) [inputs]: Add unicode-emoji and
unicode-cldr-common.
[configure-flags]: Add flags for emoji and annotations.
---
 gnu/packages/ibus.scm | 13 +++++++++++--
 1 file changed, 11 insertions(+), 2 deletions(-)

Comments

Ricardo Wurmus Jan. 16, 2020, 9:10 p.m. UTC | #1
Leo Prikler <leo.prikler@student.tugraz.at> writes:

> * gnu/packages/ibus.scm (ibus) [inputs]: Add unicode-emoji and
> unicode-cldr-common.
> [configure-flags]: Add flags for emoji and annotations.

This should be “arguments”, not “configure-flags”.  Also: please remove
the space between “(ibus)” and “[inputs]”.

>      (arguments
>       `(#:tests? #f  ; tests fail because there's no connection to dbus
> -       #:configure-flags `("--disable-emoji-dict" ; cannot find emoji.json path
> -                           "--enable-python-library"
> +       #:configure-flags `("--enable-python-library"
> +                           ,(string-append
> +                             "--with-unicode-emoji-dir="
> +                             (assoc-ref %build-inputs "unicode-emoji")
> +                             "/share/unicode/emoji")
> +                           ,(string-append
> +                             "--with-emoji-annotation-dir="
> +                             (assoc-ref %build-inputs "unicode-cldr-common")
> +                             "/share/unicode/cldr/common/annotations")
>                             ,(string-append "--with-ucd-dir="
>                                             (getcwd) "/ucd")
>                             "--enable-wayland")

Now that the configure flags are so long I have a preference for
dropping quoting and using (list …) instead.  All that unquoting looks a
little too noisy.

> @@ -241,6 +248,8 @@ conventions.")
>       `(("glib" ,glib "bin") ; for glib-genmarshal
>         ("gobject-introspection" ,gobject-introspection) ; for g-ir-compiler
>  
> +       ("unicode-emoji" ,unicode-emoji)
> +       ("unicode-cldr-common" ,unicode-cldr-common)
>         ;; XXX TODO: Move Unicode data to its own (versioned) package.
>         ("unicode-nameslist"
>          ,(origin

Oh, here is the comment I mentioned earlier!
diff mbox series

Patch

diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index 87e086a458..66cfb10068 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -161,8 +161,15 @@  conventions.")
     (build-system glib-or-gtk-build-system)
     (arguments
      `(#:tests? #f  ; tests fail because there's no connection to dbus
-       #:configure-flags `("--disable-emoji-dict" ; cannot find emoji.json path
-                           "--enable-python-library"
+       #:configure-flags `("--enable-python-library"
+                           ,(string-append
+                             "--with-unicode-emoji-dir="
+                             (assoc-ref %build-inputs "unicode-emoji")
+                             "/share/unicode/emoji")
+                           ,(string-append
+                             "--with-emoji-annotation-dir="
+                             (assoc-ref %build-inputs "unicode-cldr-common")
+                             "/share/unicode/cldr/common/annotations")
                            ,(string-append "--with-ucd-dir="
                                            (getcwd) "/ucd")
                            "--enable-wayland")
@@ -241,6 +248,8 @@  conventions.")
      `(("glib" ,glib "bin") ; for glib-genmarshal
        ("gobject-introspection" ,gobject-introspection) ; for g-ir-compiler
 
+       ("unicode-emoji" ,unicode-emoji)
+       ("unicode-cldr-common" ,unicode-cldr-common)
        ;; XXX TODO: Move Unicode data to its own (versioned) package.
        ("unicode-nameslist"
         ,(origin