diff mbox series

[bug#39086,3/5] gnu: Add unicode-cldr-common.

Message ID 20200111120829.29821-3-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#39086,1/5] licenses: Add Unicode license. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Leo Prikler Jan. 11, 2020, 12:08 p.m. UTC
* gnu/packages/ibus (unicode-cldr-commmon): New package.
---
 gnu/packages/ibus.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

Ricardo Wurmus Jan. 16, 2020, 9:08 p.m. UTC | #1
Leo Prikler <leo.prikler@student.tugraz.at> writes:

> * gnu/packages/ibus (unicode-cldr-commmon): New package.

This should be:

    * gnu/packages/ibus.scm (unicode-cldr-commmon): New variable.

You know, I wonder if these things really belong to ibus.scm.  I
remember a TODO somewhere in the code that bemoaned the lack of
versioned Unicode data files.  Perhaps we should just add a new module
(gnu packages unicode) — what do you think?

> +(define-public unicode-cldr-common
> +  (package
> +    (name "unicode-cldr-common")
> +    (version "36")
> +    (source
> +     (origin (method url-fetch/zipbomb)
> +             (uri "https://unicode.org/Public/cldr/36/cldr-common-36.0.zip")
> +             (sha256
> +              (base32
> +
> "0hxsc3j5zb32hmiaj0r3ajchmklx6zng6zlh1ca6s9plq5b9w9q7"))))

The version should be “36.0”.  The source URI should reference the
version field twice.

> +    (description
> +     "The Unicode Common Locale Data Repository (CLDR) is a large repository of
> +locale data, including among others
> +- patterns for formatting and parsing,
> +- name translations,
> +- and various informations on languages, scripts and country-specific
> +conventions.")
> +    (license unicode)))

Please use @enumerate or @itemize texinfo syntax here.
Leo Prikler Jan. 16, 2020, 10:53 p.m. UTC | #2
Am Donnerstag, den 16.01.2020, 22:08 +0100 schrieb Ricardo Wurmus:
> Leo Prikler <leo.prikler@student.tugraz.at> writes:
> 
> > * gnu/packages/ibus (unicode-cldr-commmon): New package.
> 
> This should be:
> 
>     * gnu/packages/ibus.scm (unicode-cldr-commmon): New variable.
> 
> You know, I wonder if these things really belong to ibus.scm.  I
> remember a TODO somewhere in the code that bemoaned the lack of
> versioned Unicode data files.  Perhaps we should just add a new
> module
> (gnu packages unicode) — what do you think?
I don't mind either way, but these packages don't fix the TODO.  They
add yet unseen features.

> > +(define-public unicode-cldr-common
> > +  (package
> > +    (name "unicode-cldr-common")
> > +    (version "36")
> > +    (source
> > +     (origin (method url-fetch/zipbomb)
> > +             (uri "
> > https://unicode.org/Public/cldr/36/cldr-common-36.0.zip")
> > +             (sha256
> > +              (base32
> > +
> > "0hxsc3j5zb32hmiaj0r3ajchmklx6zng6zlh1ca6s9plq5b9w9q7"))))
> 
> The version should be “36.0”.  The source URI should reference the
> version field twice.
The thing is, the Unicode people are really messy with their
versioning, so I feel safer if I at least just use version once. 
Basically, they have 36/36.0, but 36.1/36.1, which makes no sense
whatsoever.

> 
> > +    (description
> > +     "The Unicode Common Locale Data Repository (CLDR) is a large
> > repository of
> > +locale data, including among others
> > +- patterns for formatting and parsing,
> > +- name translations,
> > +- and various informations on languages, scripts and country-
> > specific
> > +conventions.")
> > +    (license unicode)))
> 
> Please use @enumerate or @itemize texinfo syntax here.
Will do.
Ricardo Wurmus Jan. 17, 2020, 7:41 a.m. UTC | #3
Leo Prikler <leo.prikler@student.tugraz.at> writes:

> Am Donnerstag, den 16.01.2020, 22:08 +0100 schrieb Ricardo Wurmus:
>> Leo Prikler <leo.prikler@student.tugraz.at> writes:
>> 
>> > * gnu/packages/ibus (unicode-cldr-commmon): New package.
>> 
>> This should be:
>> 
>>     * gnu/packages/ibus.scm (unicode-cldr-commmon): New variable.
>> 
>> You know, I wonder if these things really belong to ibus.scm.  I
>> remember a TODO somewhere in the code that bemoaned the lack of
>> versioned Unicode data files.  Perhaps we should just add a new
>> module
>> (gnu packages unicode) — what do you think?
> I don't mind either way, but these packages don't fix the TODO.  They
> add yet unseen features.

That’s okay.  I just think we should start that new unicode.scm module
to finally have a place for these data files.  That would be a more
appropriate place than ibus.scm.
diff mbox series

Patch

diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index 3d582fb935..87e086a458 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -114,6 +114,38 @@ 
      "Data files for the Unicode Technological Standard #51 (Emoji).")
     (license unicode)))
 
+(define-public unicode-cldr-common
+  (package
+    (name "unicode-cldr-common")
+    (version "36")
+    (source
+     (origin (method url-fetch/zipbomb)
+             (uri "https://unicode.org/Public/cldr/36/cldr-common-36.0.zip")
+             (sha256
+              (base32
+               "0hxsc3j5zb32hmiaj0r3ajchmklx6zng6zlh1ca6s9plq5b9w9q7"))))
+    (build-system trivial-build-system)
+    (arguments
+     `(#:modules ((guix build utils))
+       #:builder
+       (let ((out (string-append %output "/share/unicode/cldr/common")))
+         (use-modules (guix build utils))
+         (mkdir-p out)
+         (copy-recursively (string-append (assoc-ref %build-inputs "source")
+                                          "/common")
+                           out)
+         #t)))
+    (home-page "https://www.unicode.org")
+    (synopsis "Locale data repository")
+    (description
+     "The Unicode Common Locale Data Repository (CLDR) is a large repository of
+locale data, including among others
+- patterns for formatting and parsing,
+- name translations,
+- and various informations on languages, scripts and country-specific
+conventions.")
+    (license unicode)))
+
 (define-public ibus
   (package
     (name "ibus")