diff mbox series

[bug#38652,5/5] gnu: Add python-pathos.

Message ID 20191217172437.21217-5-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#38652,1/5] gnu: python-dill: Update to 0.3.1.1. | expand

Commit Message

Mădălin Ionel Patrașcu Dec. 17, 2019, 5:24 p.m. UTC
* gnu/packages/python-xyz.scm (python-pathos, python2-pathos): New variables.
---
 gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Ricardo Wurmus Dec. 18, 2019, 11 p.m. UTC | #1
Hi Mădălin,

> * gnu/packages/python-xyz.scm (python-pathos, python2-pathos): New variables.

I can’t seem to get the tests to run.  I tried this:

--8<---------------cut here---------------start------------->8---
(define-public python-pathos
  (package
    (name "python-pathos")
    (version "0.2.5")
    (source
     (origin
       (method url-fetch)
       (uri (pypi-uri "pathos" version))
       (sha256
        (base32
         "0in8hxdz7k081ijn6q94gr39ycy7363sx4zysmbwyvd7snqjrbi1"))))
    (build-system python-build-system)
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (replace 'check
           (lambda _
             (invoke "py.test" "-vvv" "tests")
             #t)))))
    (propagated-inputs
     `(("python-dill" ,python-dill)
       ("python-multiprocess" ,python-multiprocess)
       ("python-pox" ,python-pox)
       ("python-ppft" ,python-ppft)))
    (native-inputs
     `(("python-pytest" ,python-pytest)))
    (home-page "https://pypi.org/project/pathos/")
    (synopsis "Parallel graph management and execution in heterogeneous computing")
    (description
     "Pathos is a framework for heterogenous computing.  It provides a
consistent high-level interface for configuring and launching parallel
computations across heterogenous resources.  Pathos provides configurable
launchers for parallel and distributed computing, where each launcher contains
the syntactic logic to configure and launch jobs in an execution
environment.")
    (license license:bsd-3)))
--8<---------------cut here---------------end--------------->8---

…but after collecting 15 tests it just hangs, doing nothing.

> +(define-public python2-pathos
> +  (package-with-python2 python-pathos))

If you define a Python 2 variant you should also define Python 2
variants for all its inputs.
Efraim Flashner Dec. 19, 2019, 7:31 a.m. UTC | #2
On Tue, Dec 17, 2019 at 06:24:37PM +0100, Mădălin Ionel Patrașcu wrote:
> * gnu/packages/python-xyz.scm (python-pathos, python2-pathos): New variables.
> ---
> +
> +(define-public python2-pathos
> +  (package-with-python2 python-pathos))
> 

With the impending end of life on python2 we're not automatically adding
python2 variants of packages unless they're actually used.
Efraim Flashner Dec. 26, 2019, 7:40 a.m. UTC | #3
I pushed this patch and managed to get the test suite to run.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2287903d0b..edaefe7575 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16958,3 +16958,34 @@  unix shell commands such as which and find.  These commands allow automated
 discovery of what has been installed on an operating system, and where the
 essential tools are located.")
     (license license:bsd-3)))
+
+(define-public python-pathos
+  (package
+    (name "python-pathos")
+    (version "0.2.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pathos" version))
+       (sha256
+        (base32
+         "0in8hxdz7k081ijn6q94gr39ycy7363sx4zysmbwyvd7snqjrbi1"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-dill" ,python-dill)
+       ("python-multiprocess" ,python-multiprocess)
+       ("python-pox" ,python-pox)
+       ("python-ppft" ,python-ppft)))
+    (home-page "https://pypi.org/project/pathos/")
+    (synopsis
+     "Parallel graph management and execution in heterogeneous computing")
+    (description
+     "Python-pathos is a framework for heterogenous computing.  It provides a
+consistent high-level interface for configuring and launching parallel
+computations across heterogenous resources.  Python-pathos provides configurable
+launchers for parallel and distributed computing, where each launcher contains
+the syntactic logic to configure and launch jobs in an execution environment.")
+    (license license:bsd-3)))
+
+(define-public python2-pathos
+  (package-with-python2 python-pathos))