diff mbox series

[bug#38652,4/5] gnu: Add python-pox.

Message ID 20191217172437.21217-4-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#38652,1/5] gnu: python-dill: Update to 0.3.1.1. | expand

Commit Message

Mădălin Ionel Patrașcu Dec. 17, 2019, 5:24 p.m. UTC
* gnu/packages/python-xyz.scm (python-pox): New variable.
---
 gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f5b2ff16e7..2287903d0b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16934,3 +16934,27 @@  multiprocessing) computers and clusters.  pp module features cross-platform
 portability and dynamic load balancing.")
     ;; looks like bsd-3 https://github.com/uqfoundation/ppft/blob/master/LICENSE
     (license license:bsd-3)))
+
+(define-public python-pox
+  (package
+    (name "python-pox")
+    (version "0.2.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pox" version))
+       (sha256
+        (base32
+         "0y17ckc2p6i6709s279sjdj4q459mpcc38ymg9zv9y6vl6jf3bq6"))))
+    (build-system python-build-system)
+    (home-page "https://pypi.org/project/pox/")
+    (synopsis "Python utilities for filesystem exploration and automated builds")
+    (description
+     "Python-pox provides a collection of utilities for navigating and
+manipulating filesystems.  This module is designed to facilitate some of the
+low level operating system interactions that are useful when exploring a
+filesystem on a remote host.  Python-pox provides python equivalents of several
+unix shell commands such as which and find.  These commands allow automated
+discovery of what has been installed on an operating system, and where the
+essential tools are located.")
+    (license license:bsd-3)))