diff mbox series

[bug#38652,3/5] gnu: Add python-ppft.

Message ID 20191217172437.21217-3-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#38652,1/5] gnu: python-dill: Update to 0.3.1.1. | expand

Commit Message

Mădălin Ionel Patrașcu Dec. 17, 2019, 5:24 p.m. UTC
* gnu/packages/python-xyz.scm (python-ppft): New variable.

Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
---
 gnu/packages/python-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Ricardo Wurmus Dec. 18, 2019, 4:28 p.m. UTC | #1
Hi Mădălin,

> * gnu/packages/python-xyz.scm (python-ppft): New variable.
[…]
> +    (arguments
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         (replace 'check
> +           (lambda _
> +             (with-directory-excursion "/tmp"
> +               (invoke "nosetests" "-v"))
> +             #t)))))

This has the effect of not running the tests at all.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index acc030fb9b..f5b2ff16e7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16899,3 +16899,38 @@  always possible to declare a command with the highest possible (and least
 flexible) layer and then tune the behaviour with any of the lower layers
 including the native API of @code{python-argparse}.")
       (license license:lgpl3+))))
+
+(define-public python-ppft
+  (package
+    (name "python-ppft")
+    (version "1.6.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ppft" version))
+       (sha256
+        (base32
+         "1z1invkhszc5d2mvgr221v7cszzifcc77mz0pv3wjp6x5q2768cy"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (with-directory-excursion "/tmp"
+               (invoke "nosetests" "-v"))
+             #t)))))
+    (native-inputs
+     `(("python-nose" ,python-nose)))
+    (propagated-inputs
+     `(("python-six" ,python-six)))
+    (home-page "https://pypi.org/project/ppft/")
+    (synopsis "Fork of Parallel Python")
+    (description
+     "This package phython-ppft is a fork of Parallel Python, and is developed
+as part of python-pathos.  Parallel Python module (pp) provides an easy and
+efficient way to create parallel-enabled applications for SMP (symmetric
+multiprocessing) computers and clusters.  pp module features cross-platform
+portability and dynamic load balancing.")
+    ;; looks like bsd-3 https://github.com/uqfoundation/ppft/blob/master/LICENSE
+    (license license:bsd-3)))