diff mbox series

[bug#35705,7/9] gnu: Add python-sphinxcontrib-htmlhelp.

Message ID 20190512221221.17781-7-mbakke@fastmail.com
State Accepted
Headers show
Series Sphinx 2.0 | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Marius Bakke May 12, 2019, 10:12 p.m. UTC
* gnu/packages/sphinx.scm (python-sphinxcontrib-htmlhelp): New public variable.
---
 gnu/packages/sphinx.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index b782504d46..4bf737b8f2 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -135,6 +135,26 @@  Apple help books.")
 @url{Devhelp,https://wiki.gnome.org/Apps/Devhelp} documents.")
     (license license:bsd-2)))
 
+(define-public python-sphinxcontrib-htmlhelp
+  (package
+    (name "python-sphinxcontrib-htmlhelp")
+    (version "1.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "sphinxcontrib-htmlhelp" version))
+              (sha256
+               (base32
+                "08l4x8a2l4xjqdd5rhvmfsqihmlgg4prdayj9b6pigaii6gzjw26"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))                    ;XXX: circular dependency on Sphinx
+    (home-page "https://github.com/sphinx-doc/sphinxcontrib-htmlhelp")
+    (synopsis "Sphinx exension for rendering HTML help files")
+    (description
+     "@code{sphinxcontrib-htmlhelp} is a Sphinx extension which renders
+HTML help files.")
+    (license license:bsd-2)))
+
 (define-public python-sphinxcontrib-jsmath
   (package
     (name "python-sphinxcontrib-jsmath")