diff mbox series

[bug#35705,6/9] gnu: Add python-sphinxcontrib-jsmath.

Message ID 20190512221221.17781-6-mbakke@fastmail.com
State Accepted
Headers show
Series Sphinx 2.0 | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Marius Bakke May 12, 2019, 10:12 p.m. UTC
* gnu/packages/sphinx.scm (python-sphinxcontrib-jsmath): New public variable.
---
 gnu/packages/sphinx.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index b184dc4e8c..b782504d46 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -135,6 +135,26 @@  Apple help books.")
 @url{Devhelp,https://wiki.gnome.org/Apps/Devhelp} documents.")
     (license license:bsd-2)))
 
+(define-public python-sphinxcontrib-jsmath
+  (package
+    (name "python-sphinxcontrib-jsmath")
+    (version "1.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "sphinxcontrib-jsmath" version))
+              (sha256
+               (base32
+                "1f64w19j33sp151jimibraw6qrbhd5gxy8hs3797w9478m55x4m9"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))                    ;XXX: circular dependency on Sphinx
+    (home-page "https://github.com/sphinx-doc/sphinxcontrib-jsmath")
+    (synopsis "Sphinx extension to render math equations")
+    (description
+     "@code{sphinxcontrib-jsmath} is a Sphinx extension which renders display
+math in HTML via JavaScript.")
+    (license license:bsd-3)))
+
 (define-public python-sphinxcontrib-newsfeed
   (package
     (name "python-sphinxcontrib-newsfeed")