diff mbox series

[bug#35705,4/9] gnu: Add python-sphinxcontrib-applehelp.

Message ID 20190512221221.17781-4-mbakke@fastmail.com
State Accepted
Headers show
Series Sphinx 2.0 | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Marius Bakke May 12, 2019, 10:12 p.m. UTC
* gnu/packages/sphinx.scm (python-sphinxcontrib-applehelp): New public variable.
---
 gnu/packages/sphinx.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 1810716e6b..4e5b791a6f 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -95,6 +95,26 @@  for Python projects or other documents consisting of multiple reStructuredText
 sources.")
     (license license:bsd-3)))
 
+(define-public python-sphinxcontrib-applehelp
+  (package
+    (name "python-sphinxcontrib-applehelp")
+    (version "1.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "sphinxcontrib-applehelp" version))
+              (sha256
+               (base32
+                "15rqmgphj4wqf4m5wnzxgmwxx5jwfzb0j0nb94ql0x5wnar0mapd"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))                    ;XXX: circular dependency on Sphinx
+    (home-page "https://github.com/sphinx-doc/sphinxcontrib-applehelp")
+    (synopsis "Sphinx extension for creating Apple help books")
+    (description
+     "@code{sphinxcontrib-applehelp} is a Sphinx extension which outputs
+Apple help books.")
+    (license license:bsd-2)))
+
 (define-public python-sphinxcontrib-newsfeed
   (package
     (name "python-sphinxcontrib-newsfeed")