diff mbox series

[bug#35545,08/17] gnu: Add java-openjfx-base.

Message ID 20190503130134.24788-8-julien@lepiller.eu
State Accepted
Headers show
Series [bug#35545,01/17] gnu: Add java-signpost-core. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Julien Lepiller May 3, 2019, 1:01 p.m. UTC
* gnu/packages/java.scm (java-openjfx-base): New variable.
---
 gnu/packages/java.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Nicolas Goaziou May 3, 2019, 3:15 p.m. UTC | #1
Hello,

Julien Lepiller <julien@lepiller.eu> writes:

> +         (add-before 'check 'remove-empty-file
> +           (lambda _
> +             (with-directory-excursion "modules/base/src/test/java"
> +               ;; These files are completely commented, but junit expects them to
> +               ;; contain a class, so tests fail.
> +               (delete-file
> +                 "com/sun/javafx/property/adapter/PropertyDescriptorTest.java")
> +               (delete-file
> +                 "com/sun/javafx/property/adapter/ReadOnlyPropertyDescriptorTest.java")
> +               (delete-file "javafx/beans/property/PropertiesTest.java")
> +               (delete-file
> +                 "javafx/beans/property/adapter/ReadOnlyJavaBeanPropertyBuilder_General_Test.java")
> +               ;; This one fails
> +               (delete-file "com/sun/javafx/runtime/VersionInfoTest.java")))))))

This phase doesn't end with #t.

Regards,
Julien Lepiller May 4, 2019, 11:38 a.m. UTC | #2
Le Fri, 03 May 2019 17:15:05 +0200,
Nicolas Goaziou <mail@nicolasgoaziou.fr> a écrit :

> Hello,
> 
> Julien Lepiller <julien@lepiller.eu> writes:
> 
> > +         (add-before 'check 'remove-empty-file
> > +           (lambda _
> > +             (with-directory-excursion "modules/base/src/test/java"
> > +               ;; These files are completely commented, but junit
> > expects them to
> > +               ;; contain a class, so tests fail.
> > +               (delete-file
> > +
> > "com/sun/javafx/property/adapter/PropertyDescriptorTest.java")
> > +               (delete-file
> > +
> > "com/sun/javafx/property/adapter/ReadOnlyPropertyDescriptorTest.java")
> > +               (delete-file
> > "javafx/beans/property/PropertiesTest.java")
> > +               (delete-file
> > +
> > "javafx/beans/property/adapter/ReadOnlyJavaBeanPropertyBuilder_General_Test.java")
> > +               ;; This one fails
> > +               (delete-file
> > "com/sun/javafx/runtime/VersionInfoTest.java")))))))  
> 
> This phase doesn't end with #t.
> 
> Regards,
> 

Thanks! I fixed that and your comment on patch 07. Is there anything
more? Do you need more time for a complete review or have you reviewed
everything already?
Ricardo Wurmus May 4, 2019, 11:46 a.m. UTC | #3
Julien Lepiller <julien@lepiller.eu> writes:

> * gnu/packages/java.scm (java-openjfx-base): New variable.
[…]
> +       #:source-dir "modules/base/src/main/java:modules/base/src/main/java8:modules/base/src/main/version-info"

This line is very long.  Could you use (string-join …) on a list of
directories instead?

> +       #:test-dir "modules/base/src/test"
> +       #:phases
> +       (modify-phases %standard-phases
> +         (add-before 'check 'remove-empty-file

“files”, because it’s more than one?

> +    (description "OpenJFX is a free, next generation client application

Please remove “free” and “next generation”.
Nicolas Goaziou May 4, 2019, 9:03 p.m. UTC | #4
Hello,

Julien Lepiller <julien@lepiller.eu> writes:

> Thanks! I fixed that and your comment on patch 07. Is there anything
> more? Do you need more time for a complete review or have you reviewed
> everything already?

I read your patches in order to learn a bit more about the Ant build
system, which I never used before. I didn't find any obvious typo in the
rest of the patches, but I cannot comment on the build part.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 65d2baef21..9d2019ddc5 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2257,6 +2257,37 @@  OpenJFX distribution and helper classes for building other parts of the
 distribution.")
     (license license:gpl2)));with classpath exception
 
+(define-public java-openjfx-base
+  (package (inherit java-openjfx-build)
+    (name "java-openjfx-base")
+    (arguments
+     `(#:jar-name "java-openjfx-base.jar"
+       #:source-dir "modules/base/src/main/java:modules/base/src/main/java8:modules/base/src/main/version-info"
+       #:test-dir "modules/base/src/test"
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'remove-empty-file
+           (lambda _
+             (with-directory-excursion "modules/base/src/test/java"
+               ;; These files are completely commented, but junit expects them to
+               ;; contain a class, so tests fail.
+               (delete-file
+                 "com/sun/javafx/property/adapter/PropertyDescriptorTest.java")
+               (delete-file
+                 "com/sun/javafx/property/adapter/ReadOnlyPropertyDescriptorTest.java")
+               (delete-file "javafx/beans/property/PropertiesTest.java")
+               (delete-file
+                 "javafx/beans/property/adapter/ReadOnlyJavaBeanPropertyBuilder_General_Test.java")
+               ;; This one fails
+               (delete-file "com/sun/javafx/runtime/VersionInfoTest.java")))))))
+    (propagated-inputs
+     `(("java-openjfx-build" ,java-openjfx-build)))
+    (description "OpenJFX is a free, next generation client application
+platform for desktop, mobile and embedded systems built on Java.  Its goal
+is to produce a modern, efficient, and fully featured toolkit for developing
+rich client applications.  This package contains base classes for the
+OpenJFX distribution.")))
+
 (define-public javacc-4
   (package
     (name "javacc")