diff mbox series

[bug#35545,04/17] gnu: Add java-xmp.

Message ID 20190503130134.24788-4-julien@lepiller.eu
State Accepted
Headers show
Series [bug#35545,01/17] gnu: Add java-signpost-core. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Julien Lepiller May 3, 2019, 1:01 p.m. UTC
* gnu/packages/java.scm (java-xmp): New variable.
---
 gnu/packages/java.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

Comments

Björn Höfling May 5, 2019, 10:52 a.m. UTC | #1
On Fri,  3 May 2019 15:01:21 +0200
Julien Lepiller <julien@lepiller.eu> wrote:

> * gnu/packages/java.scm (java-xmp): New variable.
> ---
>  gnu/packages/java.scm | 39 +++++++++++++++++++++++++++++++++++++++
>  1 file changed, 39 insertions(+)
> 
> diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
> index d0bbc4b682..ee54e936bc 100644
> --- a/gnu/packages/java.scm
> +++ b/gnu/packages/java.scm
> @@ -11098,3 +11098,42 @@ and allows to build a Java object model for
> JSON text using API classes (description "JSON Processing (JSON-P) is
> a Java API to process (e.g. parse, generate, transform and query)
> JSON messages.  This package contains a reference implementation of
> that API."))) +
> +(define-public java-xmp
> +  (package
> +    (name "java-xmp")
> +    (version "5.1.3")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append
> "http://download.macromedia.com/pub/developer"
> +                                  "/xmp/sdk/XMPCoreJava-" version
> ".zip"))
> +              (sha256
> +               (base32
> +
> "14nai2mmsg7l5ya2y5mx4w4lr1az3sk2fjz6hiy4zdrsavgvl1g7"))))
> +    (build-system ant-build-system)
> +    (arguments
> +     `(#:build-target "build"
> +       #:tests? #f; no tests
> +       #:phases
> +       (modify-phases %standard-phases
> +         (add-after 'unpack 'chdir
> +           (lambda _
> +             (chdir "XMPCore")
> +             #t))
> +         (replace 'install
> +           (install-jars "."))
> +         (add-after 'install 'install-doc
> +           (lambda* (#:key outputs #:allow-other-keys)
> +             (copy-recursively
> +               "docs"
> +               (string-append (assoc-ref outputs "out")
> "/share/doc/java-xmp"))
> +             #t)))))
> +    (native-inputs
> +     `(("unzip" ,unzip)))
> +    (home-page "https://www.adobe.com/devnet/xmp.html")
> +    (synopsis "Extensible Metadat Platform (XMP) support in Java")
> +    (description "Adobe's Extensible Metadata Platform (XMP) is a
> labeling +technology that allows you to embed data about a file,
> known as metadata, +into the file itself.  The XMP Toolkit for Java
> is based on the C++ XMPCore +library and the API is similar.")
> +    (license license:bsd-3)))




This is NOT reproducible:

│ ├── java
│ │ ├── xmpcore.jar
│ │ │ ├── zipinfo -v {}
│ │ │ │ @@ -82,15 +82,15 @@
│ │ │ │    version of encoding software:                   3.0
│ │ │ │    minimum file system compatibility required:     MS-DOS, OS/2 or NT FAT
│ │ │ │    minimum software version required to extract:   1.0
│ │ │ │    compression method:                             none (stored)
│ │ │ │    file security status:                           not encrypted
│ │ │ │    extended local header:                          no
│ │ │ │    file last modified on (DOS date/time):          1980 Jan 1 00:00:00
│ │ │ │ -  32-bit CRC value (hex):                         e6bc1834
│ │ │ │ +  32-bit CRC value (hex):                         1e47a4b8
│ │ │ │    compressed size:                                436 bytes
│ │ │ │    uncompressed size:                              436 bytes
│ │ │ │    length of filename:                             20 characters
│ │ │ │    length of extra field:                          0 bytes
│ │ │ │    length of file comment:                         0 characters
│ │ │ │    disk number on which file begins:               disk 1
│ │ │ │    apparent file type:                             binary
│ │ │ ├── META-INF/MANIFEST.MF
│ │ │ │ @@ -5,10 +5,10 @@
│ │ │ │  Implementation-Vendor: Copyright 2006-2009 Adobe Systems Incorporated.
│ │ │ │    All rights reserved
│ │ │ │  Implementation-Major: 5
│ │ │ │  Implementation-Minor: 1
│ │ │ │  Implementation-Micro: 3
│ │ │ │  Implementation-Debug: false
│ │ │ │  Implementation-EngBuild: 003
│ │ │ │ -BuildDate: 2019 May 05 10:43:42-GMT
│ │ │ │ +BuildDate: 2019 May 05 10:43:37-GMT
│ │ │ │  AdobeIP: <AdobeIP#0000856>


Could you have a look at it?

Otherwise, LGTM.

Björn
diff mbox series

Patch

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index d0bbc4b682..ee54e936bc 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -11098,3 +11098,42 @@  and allows to build a Java object model for JSON text using API classes
     (description "JSON Processing (JSON-P) is a Java API to process (e.g.
 parse, generate, transform and query) JSON messages.  This package contains
 a reference implementation of that API.")))
+
+(define-public java-xmp
+  (package
+    (name "java-xmp")
+    (version "5.1.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://download.macromedia.com/pub/developer"
+                                  "/xmp/sdk/XMPCoreJava-" version ".zip"))
+              (sha256
+               (base32
+                "14nai2mmsg7l5ya2y5mx4w4lr1az3sk2fjz6hiy4zdrsavgvl1g7"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:build-target "build"
+       #:tests? #f; no tests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'chdir
+           (lambda _
+             (chdir "XMPCore")
+             #t))
+         (replace 'install
+           (install-jars "."))
+         (add-after 'install 'install-doc
+           (lambda* (#:key outputs #:allow-other-keys)
+             (copy-recursively
+               "docs"
+               (string-append (assoc-ref outputs "out") "/share/doc/java-xmp"))
+             #t)))))
+    (native-inputs
+     `(("unzip" ,unzip)))
+    (home-page "https://www.adobe.com/devnet/xmp.html")
+    (synopsis "Extensible Metadat Platform (XMP) support in Java")
+    (description "Adobe's Extensible Metadata Platform (XMP) is a labeling
+technology that allows you to embed data about a file, known as metadata,
+into the file itself.  The XMP Toolkit for Java is based on the C++ XMPCore
+library and the API is similar.")
+    (license license:bsd-3)))