diff mbox series

[bug#35545,13/17] gnu: Add java-jboss-transaction-api-spec.

Message ID 20190503130134.24788-13-julien@lepiller.eu
State Accepted
Headers show
Series [bug#35545,01/17] gnu: Add java-signpost-core. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Julien Lepiller May 3, 2019, 1:01 p.m. UTC
* gnu/packages/java.scm (java-jboss-transaction-api-spec): New variable.
---
 gnu/packages/java.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Björn Höfling May 5, 2019, 10:07 p.m. UTC | #1
On Fri,  3 May 2019 15:01:30 +0200
Julien Lepiller <julien@lepiller.eu> wrote:

> * gnu/packages/java.scm (java-jboss-transaction-api-spec): New
> variable. ---

> +(define-public java-jboss-transaction-api-spec
> +  (package
> +    (name "java-jboss-transaction-api-spec")
> +    (version "1.2")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                     (url
> "https://github.com/jboss/jboss-transaction-api_spec")
> +                     (commit
> "c20742e0a8f1e0447d72d42be981050f3857b3f1")))
> +              (file-name (git-file-name name version))

I think it would be better to reference this commit via the tag:

jboss-transaction-api_1.2_spec-1.1.1.Final

Concerning the version, the pom.xml has:

   <groupId>org.jboss.spec.javax.transaction</groupId>
   <artifactId>jboss-transaction-api_1.2_spec</artifactId>
   <version>1.1.1.Final</version>

Wouldn't it be better to use the full version (API-version+package-version) as in the pom? 


> +    (license (list license:gpl2 license:cddl1.0)))); either gpl2
> only or cddl.

gpl2+classpath

Björn
diff mbox series

Patch

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index ede24d130c..3528d3449e 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -11343,3 +11343,32 @@  It's in particular targeted for making it easy to integrate SVG into Java
 games and making it much easier for artists to design 2D game content - from
 rich interactive menus to charts and graphcs to complex animations.")
     (license license:bsd-2)))
+
+(define-public java-jboss-transaction-api-spec
+  (package
+    (name "java-jboss-transaction-api-spec")
+    (version "1.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/jboss/jboss-transaction-api_spec")
+                     (commit "c20742e0a8f1e0447d72d42be981050f3857b3f1")))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1xbfq5hvb86izflydxrqqv3k26c1ba2m0ap6m97shqrsdi9by4wy"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:jar-name "java-jboss-transaction-api_spec.jar"
+       #:source-dir "src/main/java"
+       #:tests? #f)); no tests
+    (inputs
+     `(("java-cdi-api" ,java-cdi-api)
+       ("java-jboss-interceptors-api-spec" ,java-jboss-interceptors-api-spec)))
+    (home-page "https://github.com/jboss/jboss-transaction-api_spec")
+    (synopsis "Generic transaction management API in Java")
+    (description "Java-jboss-transaction-api-spec implements the Transactions
+API.  A transaction is a unit of work containing one or more operations
+involving one or more shared resources having ACID (Atomicity, Consistency,
+Isolation and Durability) properties.")
+    (license (list license:gpl2 license:cddl1.0)))); either gpl2 only or cddl.