diff mbox series

[bug#35449,2/7] gnu: Use license: prefix in shellutils.scm.

Message ID 20190427114307.26796-2-mail@brendan.scot
State Accepted
Headers show
Series [bug#35449,1/7] gnu: zimg: Fix license field to refer to license:wtfpl2. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Brendan Tildesley April 27, 2019, 11:43 a.m. UTC
* gnu/packages/shellutils.scm Use license: prefix in all packages.
---
 gnu/packages/shellutils.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 59a8b744eb..d8d601acfe 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -25,7 +25,7 @@ 
   #:use-module (gnu packages base)
   #:use-module (gnu packages golang)
   #:use-module (gnu packages python)
-  #:use-module (guix licenses)
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
@@ -98,7 +98,7 @@  between various shells or commands.")
 FreeDesktop.org trash can used by GNOME, KDE, XFCE, and other common desktop
 environments.  It can move files to the trash, and remove or list files that
 are already there.")
-    (license gpl2+)))
+    (license license:gpl2+)))
 
 (define-public direnv
   (package
@@ -146,7 +146,7 @@  allows project-specific environment variables without using @file{~/.profile}.
 Before each prompt, direnv checks for the existence of a @file{.envrc} file in
 the current and parent directories.  This file is then used to alter the
 environment variables of the current shell.")
-    (license expat)))
+    (license license:expat)))
 
 (define-public fzy
   (package
@@ -181,7 +181,7 @@  or different parts of the path.
 fzy is designed to be used both as an editor plugin and on the command
 line.  Rather than clearing the screen, fzy displays its interface directly
 below the current cursor position, scrolling the screen if necessary.")
-    (license expat)))
+    (license license:expat)))
 
 (define-public hstr
   (package
@@ -223,4 +223,4 @@  HSTR can also manage your command history (for instance you can remove
 commands that are obsolete or contain a piece of sensitive information) or
 bookmark your favourite commands.")
     (home-page "http://me.mindforger.com/projects/hh.html")
-    (license asl2.0)))
+    (license license:asl2.0)))